[Gta04-owner] bad wifi performance in kernel 3.3 but not with 2.6.32

Andreas Kemnade andreas at kemnade.info
Sun May 6 10:12:46 CEST 2012


Hi,

On Sat, 2012-05-05 at 20:09 +0200, Christoph Mair wrote:
> On Sat, May 5, 2012 at 4:07 PM, Andreas Kemnade <andreas at kemnade.info> wrote:
> > Hi,
> >
> > I found out that I get
> > around 1700KByte/s with kernel 2.6.32 and 2.8V for wifi at one place.
> > With Kernel 3.3 I get only 70KByte/s at the same place. iwconfig
> > shows 5.5 Mb/s then.
> > Some days ago I tried 1m away from another accesspoint with kernel 3.2,
> > also only 70KByte/s.
> >
> > Anyone knows what is going wrong there? What is the way to debug that?
> 
> Maybe just the firmware changed? This should be rather easily
> detectable. Other differences require more work to find them.
> 
Userspace (so also /lib/firmware) was same (mostly the basic LXDE rootfs
with some additions).
The LXDE rootfs and also qtmoko ships with
the debian libertas-firmware package.
I tried also the firmware from the firmware-libertas package in debian
unstable/backports after that. It does not change things much.

Greetings
Andreas Kemnade




More information about the Gta04-owner mailing list