[Gta04-owner] Building gta04 qtmoko from git

Neil Jerram neil at ossau.homelinux.net
Fri Jun 22 09:27:36 CEST 2012

Kevin Hremeviuc <khremeviuc at yahoo.com> writes:

> Hi all,
> In order to test out Neil's patch to Qtmoko I embarked upon trying to build
> qtmoko for myself.

IMO that is well worth trying.  Once past the initial hurdles of setting
up a working build system, it's great to be able to build and try
changes oneself.

> I tried the qemu buildhost method but it is just too slow - I stopped it at the
> 1.5 day mark (arm stuff does not work with kvm apparently)
> I then tried compiling on the phone itself but that was just too slow as well.

I haven't tried either of those.

> Finally I have tried cross compiling using the details in the README file in
> the top level directory of the cloned qtmoko git repository.

That's what I do too.

> This compiles fast
> but when I install the update on the phone it runs at 98% cpu and doesn't
> respond to screen touches.

Unless that's another aspect of the "QtMoko constantly restarts"
problem, I've never seen that.

> I did have to fudge a bit  regarding the two
> required 32 bit libraries libmpfr1ldbl_XXX_i386.deb and libgmp3c2_XXX_i386.deb
> (I got an Ubunutu version of libmpfr - I am on Debian Squeeze).

For the record, here's what I did for those.  (I'm on Debian Testing.)

lrwxrwxrwx 1 root root 12 May 28 21:29 /usr/lib/i386-linux-gnu/libmpfr.so.1 -> libmpfr.so.4
lrwxrwxrwx 1 root root 12 May 28 21:29 /usr/lib/i386-linux-gnu/libgmp.so.3 -> libgmp.so.10

But it appears that there are many possible solutions for those, and I
assume (or hope!) that as long as QtMoko builds, there probably aren't
any effects that get through to the built code.

> The README says
> to configure the build using '../qtmoko/configure -force-build-qt -device neo'
> which I changed to the obvious '../qtmoko/configure -force-build-qt -device
> gta04'.

Yes, me too.

> Can anyone give me some hints on what I have done wrong?

Did you build from the master_gta04 branch?

When your QtMoko is using 98% CPU, can you ssh in and try to find out
more about what is using that CPU?

Apart from that, nothing else springs to mind yet.


More information about the Gta04-owner mailing list