[Gta04-owner] Building gta04 qtmoko from git

Kevin Hremeviuc khremeviuc at yahoo.com
Fri Jun 22 03:22:37 CEST 2012

Hi all,

In order to test out Neil's patch to Qtmoko I embarked upon trying to build qtmoko for myself.

I tried the qemu buildhost method but it is just too slow - I stopped it at the 1.5 day mark (arm stuff does not work with kvm apparently)

I then tried compiling on the phone itself but that was just too slow as well.

Finally I have tried cross compiling using the details in the README file in the top level directory of the cloned qtmoko git repository. This compiles fast but when I install the update on the phone it runs at 98% cpu and doesn't respond to screen touches. I did have to fudge a bit  regarding the two required 32 bit libraries libmpfr1ldbl_XXX_i386.deb and libgmp3c2_XXX_i386.deb (I got an Ubunutu version of libmpfr - I am on Debian Squeeze). The README says to configure the build using '../qtmoko/configure -force-build-qt -device neo' which I changed to the obvious '../qtmoko/configure -force-build-qt -device gta04'.

Can anyone give me some hints on what I have done wrong?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120621/5137d975/attachment.html>

More information about the Gta04-owner mailing list