[Gta04-owner] GTA04 voice routing now working!

Radek Polak psonek2 at seznam.cz
Tue Feb 7 09:59:03 CET 2012

> A gta02 kernel on a gta04?

Ahh sorry, i pasted wrong url.

> I tried this one instead:
> http://qtmoko.sourceforge.net/debian/gta04/linux-image-3.2-qtmoko-gta04_38-
> 1_armel.deb Of course I need to boot into it with the gpio186 in the right
> state as this kernel does not export it in contrairy to my one (can send
> patch for that, if it should be included as an interim solution as long as
> there is no more intelligent rfkill mechanism looking at usb devices).

Patch would be nice, i am doing new qtmoko release and it would be nice if it 
worked on GTA04A04.

> Same problem.  arecord -D default:CARD=gta04voice -fS16_LE
> does not work either.
> arecord -D default:CARD=gta04 -fS16_LE | aplay -D default:CARD=gta04
> -fS16_LE works ok (it gives echo)
> Yes, I also tried it during a call.
> AT_ODO=0
> OK
> OK
> OK
> ATDxxxxx;
> OK

So you have no sound from umts at all? Even simple

	arecord -Dhw:1,0


	aplay -Dhw:1,0 /usr/share/sounds/alsa/some.wav

are not working?



More information about the Gta04-owner mailing list