[Gta04-owner] GTA04 voice routing now working!

Andreas Kemnade andreas at kemnade.info
Tue Feb 7 09:48:02 CET 2012


Hi,

On Tue, 7 Feb 2012 05:32:47 +0100
Radek Polak <psonek2 at seznam.cz> wrote:

> On Monday 06 February 2012 21:12:26 Andreas Kemnade wrote:
> 
> > Tried that, no success with 2.6.32
> 
> I think i dont want to spend time with this old kernel when we have nice new 
> one which is far more advanced...
>
That's ok.
 
> > With 3.2 I get
> > 
> > r1 (hw:1,0): snd_pcm_readi failed: Input/output error
> > r0 (default): overrun occured: Broken pipe
> 
> Can you please try with mine kernel [1]? Otherwise the sound card works ok?

gta04:~# uname -a
Linux gta04 3.2.0-qtmoko+ #5 PREEMPT Fri Jan 27 11:57:30 UTC 2012
armv7l GNU/Linux


A gta02 kernel on a gta04?
I tried this one instead:
http://qtmoko.sourceforge.net/debian/gta04/linux-image-3.2-qtmoko-gta04_38-1_armel.deb
Of course I need to boot into it with the gpio186 in the right state as this kernel
does not export it in contrairy to my one (can send patch for that, if it should
be included as an interim solution as long as there is no more intelligent rfkill
mechanism looking at usb devices).

Same problem.  arecord -D default:CARD=gta04voice -fS16_LE
does not work either.
arecord -D default:CARD=gta04 -fS16_LE | aplay -D default:CARD=gta04 -fS16_LE
works ok (it gives echo)

Yes, I also tried it during a call.

AT_ODO=0
OK
AT_OPCMENABLE=1
OK
AT_OPCMPROF=0
OK
ATDxxxxx;
OK

Should I check something with my osziloscope?

Greetings
Andreas Kemnade
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120207/3f3bd339/attachment-0001.bin>


More information about the Gta04-owner mailing list