[Gta04-owner] Linux 3.7 for gta04.

NeilBrown neilb at suse.de
Sat Dec 15 05:30:03 CET 2012


On Wed, 12 Dec 2012 06:29:50 +1100 NeilBrown <neilb at suse.de> wrote:

> On Tue, 11 Dec 2012 18:56:04 +0100 Radek Polak <psonek2 at seznam.cz> wrote:
> 
> > On Tuesday, December 11, 2012 05:52:17 AM NeilBrown wrote:
> > 
> > > Bug reports, success report, patches etc etc always welcome.
> > 
> > Hi Neil,
> > i have compiled it and got it running for first few minutes now. Here is what 
> > i have noticed until now:
> > 
> > 1/ battery charging: for a few first minutes it worked fine. I have unplugged 
> > it and tried a few suspend/resume. Then it showed "Discharging" even when on 
> > USB. After reboot it charges again.
> 
> Thanks for the confirmation.  I had a quick look at the 'git log' of the
> relevant files and didn't see anything obvious.  When I get a chance I add
> some debugging and see what is happening.

Someone broke the notification from the USB driver to the charger driver so
that the charger doesn't know when the USB gets plugged in so it doesn't know
to turn on charging.

commit c9721438c009adf8e81d376839ed037c53b9b8d9 causes the breakage.
I've sent a suggested fix.
In any case, it works now.

> 
> > 
> > 2/ strange greenish colors. Maybe it has to do something with:
> > 
> > omapdss DPI: Could not find exact pixel clock. Requested 22000 kHz, got 22153 
> > kHz
> 
> Again - thanks for confirming :-)  I thought I noticed that too but wasn't
> really sure and forgot to mention it.
> The earlier kernel show that same message so I don't think it is directly
> related.  There were a number of changes in the DPI code which I didn't
> understand, so I just copied the corresponding changes from other panel
> devices.  I guess I need to look at those more carefully.

I looked but I could find anything.

The only relevant change seems to be that we remove things like:

-       dssdev->panel.config = OMAP_DSS_LCD_TFT | OMAP_DSS_LCD_ONOFF | OMAP_DSS_LCD_IPC | OMAP_DSS_LCD_IVS | OMAP_DSS_LCD_IHS;


with equally meaningful things like:

+
+.vsync_level   = OMAPDSS_SIG_ACTIVE_LOW,
+.hsync_level   = OMAPDSS_SIG_ACTIVE_LOW,
+
+.data_pclk_edge        = OMAPDSS_DRIVE_SIG_FALLING_EDGE,
+.de_level      = OMAPDSS_SIG_ACTIVE_HIGH,
+.sync_pclk_edge        = OMAPDSS_DRIVE_SIG_OPPOSITE_EDGES,

to 

 static struct omap_video_timings td028ttec1_panel_timings = {

Maybe I've messed up the conversion, but I have little idea what any of them
mean and just tried to copy from similar drivers.

But maybe the problem is something else altogether.

While I was there I made this change

-.pixel_clock   = 22000,
+.pixel_clock   = 22153,

to avoid the warning.

> 
> > 
> > 3/ touching display wakes it from suspend (this was already in some older 3.5 
> > version)
> 
> Thanks for noting that - it shouldn't be hard to work out why and find a way
> to turn in on/off.

Exactly the same bug as in 3.5.  Exactly the same patch fixed it.
Maintainer said they had accepted the patch, but it didn't make it to Linus
yet :-(


> 
> > 
> > 4/ power management - i can see ~20mA in suspend, i even saw 18mA once. So 
> > it's not worse and maybe improved against 3.5!
> 
> That's good.  I'm getting terrible power usage at the moment and don't really
> know why.  Maybe I'm leaving something on which I shouldn't.  Glad to know it
> isn't a core kernel problem.
> 
> > 
> > 5/ no audio in calls, maybe some controls have changed:
> > 
> > root at neo:~# alsactl -f /opt/qtmoko/etc/alsa/gsmearpiece.state restore
> > alsactl: set_control:1255: failed to obtain info for control #21 (No such file 
> > or directory)
> 
> Is this that GTA04a4?  I don't think I have the patch to support
> hardware-routing in there.  Software routing works for me.
> 
> I should look at the hardware-routing patch.  I seem to recall there was
> something about the design that I thought could be improved - but never got
> further.
> 

I haven't looked at this yet but hope to soon.
Meanwhile an "omap-twl4030.c" has appeared which might mean we can get rid of
gta04-audio.c.  I'll look into that too.

All the fixes mentioned above have been merged into my 'mainline' branch.
I've also got the PWM driver (which drives the backlight) nearly ready of
acceptance upstream (the relevant upstream developers have been very helpful).

I'm now using 3.7 for day-to-day use (and have been doing so for at least 2
whole hours!).

NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121215/138a01ef/attachment.bin>


More information about the Gta04-owner mailing list