[Gta04-owner] Linux 3.7 for gta04.

NeilBrown neilb at suse.de
Tue Dec 11 20:29:50 CET 2012


On Tue, 11 Dec 2012 18:56:04 +0100 Radek Polak <psonek2 at seznam.cz> wrote:

> On Tuesday, December 11, 2012 05:52:17 AM NeilBrown wrote:
> 
> > Bug reports, success report, patches etc etc always welcome.
> 
> Hi Neil,
> i have compiled it and got it running for first few minutes now. Here is what 
> i have noticed until now:
> 
> 1/ battery charging: for a few first minutes it worked fine. I have unplugged 
> it and tried a few suspend/resume. Then it showed "Discharging" even when on 
> USB. After reboot it charges again.

Thanks for the confirmation.  I had a quick look at the 'git log' of the
relevant files and didn't see anything obvious.  When I get a chance I add
some debugging and see what is happening.

> 
> 2/ strange greenish colors. Maybe it has to do something with:
> 
> omapdss DPI: Could not find exact pixel clock. Requested 22000 kHz, got 22153 
> kHz

Again - thanks for confirming :-)  I thought I noticed that too but wasn't
really sure and forgot to mention it.
The earlier kernel show that same message so I don't think it is directly
related.  There were a number of changes in the DPI code which I didn't
understand, so I just copied the corresponding changes from other panel
devices.  I guess I need to look at those more carefully.

> 
> 3/ touching display wakes it from suspend (this was already in some older 3.5 
> version)

Thanks for noting that - it shouldn't be hard to work out why and find a way
to turn in on/off.

> 
> 4/ power management - i can see ~20mA in suspend, i even saw 18mA once. So 
> it's not worse and maybe improved against 3.5!

That's good.  I'm getting terrible power usage at the moment and don't really
know why.  Maybe I'm leaving something on which I shouldn't.  Glad to know it
isn't a core kernel problem.

> 
> 5/ no audio in calls, maybe some controls have changed:
> 
> root at neo:~# alsactl -f /opt/qtmoko/etc/alsa/gsmearpiece.state restore
> alsactl: set_control:1255: failed to obtain info for control #21 (No such file 
> or directory)

Is this that GTA04a4?  I don't think I have the patch to support
hardware-routing in there.  Software routing works for me.

I should look at the hardware-routing patch.  I seem to recall there was
something about the design that I thought could be improved - but never got
further.

> 
> I will keep testing...
> 
> Thanks a lot for your work

And thank you so much for testing.  It is both helpful and encouraging.
I'm flat-out this week but hope to find a slab of time next week to address
these issues and more.

NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121212/b8e88c8e/attachment.bin>


More information about the Gta04-owner mailing list