[Gta04-owner] [Community] What software are we still missing on GTA04 distributions?

NeilBrown neilb at suse.de
Sat Aug 25 13:33:15 CEST 2012

On Thu, 26 Jul 2012 10:30:48 +0200 Radek Polak <psonek2 at seznam.cz> wrote:

> On Thursday, July 26, 2012 12:52:15 AM NeilBrown wrote:
> > Reliable firmware for the GSM module?
> Me too ;-) 
> > I've recently started noticing the problem where an incoming call causes
> > the firmware to crash on occasion.  I think Radek avoided that by
> > disabling 3G or similar (Radek: what was the command to do that?).
> This is from QtMoko's modem plugin [1]:
> 	chat("AT_OPSYS=0,2");       // disable UMTS, use only GSM

I finally tried this.
My phone was not accepting or making calls, though it reported a reasonable
signal strength.
I queried the _OPSYS setting:

_OPSYS: 0,2

_OPSYS: (0-5),(0-6)

_OPSYS: 0,2

found that it was already 0,2, but set it anyway.  Then I tried making a call
and it worked.  Might have been lucky. Maybe not.

So I did some reading.  Lots of places will tell me what the first number
 0 - GSM or 2G or GPRS (opinions vary)  only
 1 - UMTS or 3G only
 2 - prefer 2G over 3G
 3 - prefer 3G over 2G
 4 - keep using whatever you are using now
 5 - automatic selection.

Then I remembered that my GSM data connection was strangely slow..
If I set _OPSYS to 3, I get about 300KB/sec.
If I set _OPSYS to 0, I get about 10KB/sec.

So... weird.  Did setting it explicitly fix something?  Will that always fix
something no matter what it is set to?  Why does it default to the slowest
option?  Does it really?

I think I might need apps to enforce different OPSYS setting so I can
experiment if it fails again.

But I'm happy that I now have fast mobile internet.

> I also added many other workarounds in QtMoko for the GSM. I think it's 
> working quite good now, but not perfectly. Here is list of problems and 
> workarounds:
> * restart QtMoko after modem crashed. AT_OPSYS=0,2 does not completely solve 
> the crashing and after the crash the serial line stops working, so i restart 
> whole QtMoko [2].

I just close/reopen whenever the tty port stops working.

> * sometimes after resume the serial line is silent - i am closing the serial 
> port before suspend and open it after resume and doing CLCC and SMS poll after 
> opened.

I don't close over resume, but I do poll for SMS if the KEY_UNKNOWN appears
on /dev/input/incoming.

> * very rarely the modem after resume simply disappeared - the serial port file 
> /dev/ttyHSO_Application was not existing at all.

I had that once that I know of.  I had to reboot.  Maybe with the A4 you can

> * cant detect other side hangup in outgoing call - i do CLCC polling.

I open /dev/ttyHS_Modem as well as ttyHS_Application.  I get a "NO CARRIER"
message on the _Modem port when the other end hangs up (if the network
notices.  If I get an incoming call to my home wire-line phone, I can hang up
then pick up again and the call is still active.  Of course I don't get NO
CARRIER in that case, but I do for mobile-to-mobile).

> I am running the phone mostly with AT logging on. But sometimes you dont have 
> time to analyze what happend.
> Currently the modem with above workarounds works quite good, but i think many 
> people expect it to be 100% perfect...
> Regards
> Radek
> > So if there were some way to try out a newer firmware, I'd be keen to give
> > it a go.

So if setting OPSYS turns out to reliably fix my problem, it looks like I
don't need new firm ware.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120825/bf6e0e77/attachment.bin>

More information about the Gta04-owner mailing list