[Gta04-owner] Status

Dr. H. Nikolaus Schaller hns at goldelico.com
Sun Sep 4 13:41:54 CEST 2011


Am 04.09.2011 um 12:40 schrieb John Ogness:

> On 2011-09-04, Dr. H. Nikolaus Schaller <hns at goldelico.com> wrote:
>> Ok, then our approach in gta04_soc_init() to allocate separate
>> platform devices should be the correct one.
> 
> Yes, although I have not studied the details of gta04_soc_init() to
> determine why it is not working for you.
> 
>> The code we have so far compiles and appears to load drivers, but
>> they are never registered as additional sound cards. While the twl
>> codec is registererd. The boot log looks like attached.
>> 
>> [...]
>> 
>> The patches I have sent to you for analysis are not yet committed to
>> the git server, but I also could submit them do a new branch.
> 
> Thanks, but that's not necessary. I can work with the git tree as it
> is and the patches you have sent.
> 
>> Maybe we should try to provide you some hardware...
> 
> I have access to a couple of OMAP3530 boards. Although they aren't
> wired up for multiple McBSP channels, I can do primitive tests to see
> if the code is doing what it should.

At least it should initialize and the multiple McBSPs should
become visible in /sys

> For example, yesterday I had 2 codecs registered on 2 different McBSP
> channels. And indeed, I had 2 sound card devices in /dev.

Great.

Or you can provide us just with a kernel source tree (any version) for the
BeagleBoard (C or XM) with multiple McBSP/sound cards?
The GTA04 is quite similar.

> Today I should have time to create a couple patches for you to
> test. Even if they don't work out-of-the-box, they may be enough to
> point you guys in the right direction so that you can continue your
> great work.

Many thanks!

Nikolaus


More information about the Gta04-owner mailing list