[Community] [Gta04-owner] Goldelico Replicant 4.2 with Wifi

Niels nift at maclisp.org
Sat Mar 15 13:04:54 CET 2014

Lukas Maerdian <luk at slyon.de> writes:

> Hi all!
> I'm glad to announce a new Replicant 4.2 testing-release for the GTA04.
> The binary, single partition image for your GTA04 can be found here:
>   http://download.goldelico.com/gta04/replicant/4.2/20140313-WiFi-4.2/
> The big change since the last release, is that basic wifi support is
> now integrated. Which means you can scan for and connect to available
> networks via the UI (incl. getting an IP address via DHCP). This makes
> the device quite a bit more usable for testers, as you can now surf
> the web or manage your mails. Please note that the first time boot of
> this system will take a bit longer as usual, as some one-time tasks
> are executed.

Hi, I tried downloading the makesd script from the above url. Ran the
script, put the sdcard in my gta04 and booted replicant. So far so

First thing I tried was to connect via wifi. But it did not work for
me. If I try to turn on wifi with the wifi slider button it will say
"on" for a while, but in a dark grey color (darker than the light grey
on the other sliders on off). After ~30 seconds it will switch to off
and stay dark gray. Tried with another sdcard, some reboots, and gave
up after a while.

I've only used qtmoko on my gta04 before, but I can't get wifi working
there either. So maybe wifi is not working on my gta04. Is there a way
to test or debug it?

Also it reports 0% for the battery (which is the old gta02 battery)
and have no indication of charging or decharging when connected to the
original openmoko usb charger. (usb cable is recognised when
connected, but not for charging).


More information about the Community mailing list