[Letux-kernel] [PATCH 0/8] Get sound playback working on the Pandora again

H. Nikolaus Schaller hns at goldelico.com
Mon Jan 10 18:03:33 CET 2022



> Am 10.01.2022 um 17:46 schrieb Grond <grond66 at riseup.net>:
>> I still see the 
>> 
>> [ 2438.947601] ti-soc-thermal 48002524.bandgap: eocz timed out waiting h
>> [ 2583.399780] omap_i2c 48060000.i2c: timeout waiting on XUDF bit
>> 
>> coming more in bursts - and unclear if it is related to ssh traffic over USB.
>> The reason why I think about that is that it starts (sometimes) if I run
>> apt-get update && apt-get upgrade over ssh. Or some git checkout. And stops when done.
>> Or it may just happen on high processor load.
> 
> Another subtle thing which may trigger it is the vibration. The nub
> driver apparently communicates with the nubs' ATMEGA microcrontrollers
> over the same I2C bus,

yes, it is the nub + touch peripheral bus.

> and the XUDF bit/i2c controller timeout messages
> can be triggered just by moving the nubs slightly (even inadvertently).

That is something I have never seen.

> You might want to try blacklisting the nub driver and see if you can
> still trigger the timeout when using apt.

Ok, will try.

Basically this brings me to an idea: are the i2c pull-up resistors not
properly enabled? Or some pull-downs enabled in parallel to hardware
pull-ups (I have not looked into the schematics)?

> 
>> 
>> This all looks like an issue with power management/idling of the processor.
>> Or some interrupt is blocked and not re-enabled.
> 
> I'm not so sure about this explanation. It does not explain how this bug
> continues to crop up on my unit when running the original OpenPandora
> 3.2 kernel. Has anyone else tried running the original kernel after
> encountering this bug? It presents slightly differently in that version;
> there is no mention of "XUDF bit" (which is the result of a later errata
> workaround failing) but the "omap_i2c.3: controller timed out" message
> (which happens after the XUDF message on the letux kernel) likely
> indicates that the same failure is present.

Yes, that is likely the same symptom.

But for me the original 3.2 kernel works fine (well, I don't have the same
user-space then so I can't test apt-get).

What I plan to test next is to install some very old known to be good kernel,
(e.g. 4.14.0 or similar) and try to trigger the xudf issue.

BR,
Nikolaus



More information about the Letux-kernel mailing list