[Letux-kernel] [PATCH 0/8] Get sound playback working on the Pandora again

Stefan Leichter sle85276 at gmx.de
Fri Jan 7 21:00:48 CET 2022


On 07.01.22 18:02, H. Nikolaus Schaller wrote:
> Maybe, can you check with lsmod if the pcm1773 module has been loaded when you see no aplay -L cards?

The pcm1773 module is loaded when I run aplay -l

letux at letux:~$ lsmod | grep -e pandora -e pcm ; aplay -l ; date
snd_soc_pcm1773        16384  1
pandora_bl             16384  0
snd_soc_omap3pandora    16384  0
pandora_nub            20480  0
aplay: device_list:270: no soundcards found...
Fri Jan  7 19:55:32 UTC 2022

>
>> Am 07.01.2022 um 18:00 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>>
>> Hi,
>>
>>> Am 07.01.2022 um 17:50 schrieb Stefan Leichter <sle85276 at gmx.de>:
>>>
>>> Hello Grond,
>>>
>>> a late happy new year and thank you for your work.
>>>
>>> On 31.12.21 01:41, Grond wrote:
>>>> Note that these changes only fix playback. Recording sound does not
>>>> currently work for as yet unknown reasons. However, given the (mind
>>>> boggling) number of ALSA kcontrols exposed by the TWL4030's sound
>>>> capture codec, it is likely that there is just a switch that is turned
>>>> off somewhere.
>>>
>>> Today I tried on my 1GHz pandora the new kernel from hns (5.16.0-rc8-letux+) with includes you patches.
>>
>> Hm. It should also include the pcm1773 driver which also makes these dmesg if it is missing.
>>
>>> Did you notice in /var/log/syslog or dmesg output the line:
>>>
>>> [   17.557952] omap3pandora-sound omap3pandora-sound: Failed to register sound card: -517
>>
>> It is -EPROBE_DEFER meaning that some required subsystem driver has not (yet) probed.
>>
>>>
>>> This can be the reason for the not working audio input. If you change in soc-core.c line 858 from dev_dbg to dev_err you will see the problem in dmesg:
>>>
>>> [   17.246490] omap3pandora-sound omap3pandora-sound: ASoC: codec component pcm1773-codec not found for link PCM1773
>>>
>>> One thing was driving me mad. When I login only via ssh aplay -l doesn't show any audio devices. After login on the pandora keyboard the playback device (pcm1773-hifi-0) appears and is usable.
>>
>> Hm. That is indeed strange. Maybe it takes too long for the pcm1773 to initialize?
>> On my 600MHz Pandora it was available immediately after boot.
>>
>> At the moment I am hunting for a different bug on a different device so I can't test.
>>
>> BR,
>> Nikolaus
>> _______________________________________________
>> https://projects.goldelico.com/p/gta04-kernel/
>> Letux-kernel mailing list
>> Letux-kernel at openphoenux.org
>> http://lists.goldelico.com/mailman/listinfo.cgi/letux-kernel
>

BR,
Stefan


More information about the Letux-kernel mailing list