[Letux-kernel] LetuxOS: Replicant for GTA04

Lukas Maerdian luk at slyon.de
Thu Oct 22 18:04:52 CEST 2020


Hi Nikolaus,

Am 20.10.20 um 20:31 schrieb H. Nikolaus Schaller:
> The status of my tests is:
> 
> Kernel 4.14.202 boots up to the Replicant logo and then stucks.
> Kernel 4.19.152 writes ANDROID to the framebuffer but then reboots - this kernel should already support the GTA04A5 if I remember correctly.
> Kernel 5.4.72 panics somewhere in omapdrm.
> Kernel 5.9.1 drivers/staging/android/logger.c does not compile (problems with struct timespec).
> 
> So there is some progress and potentially fixable issues.
> 
> The most important one is that I do not know how to debug that there
> is no progress after the Replicant logo with 4.14 kernel. There is
> no console message, processes are running but nothing visible happens.
> Touch remains inactive. Console shell works.
> 
> Ideas? Suggestions?

Uhh... I remember something like this from a few years ago.
Unfortunately, I can't remember how I fixed it back then.

IIRC it was somehow related to a missing driver, I think it was omapdrm 
or panel related :-/ I think I got it somehow solved by loading all the 
required modules (and dependencies!) manually via load_modules.sh

Best, Lukas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x618C9427E585E7C4.asc
Type: application/pgp-keys
Size: 54065 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/letux-kernel/attachments/20201022/acc80da7/attachment-0001.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 495 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/letux-kernel/attachments/20201022/acc80da7/attachment-0001.asc>


More information about the Letux-kernel mailing list