[Letux-kernel] [Lenny400] CI20: how to boot upstream kernel?

H. Nikolaus Schaller hns at goldelico.com
Mon May 13 19:27:34 CEST 2019

> Am 13.05.2019 um 19:21 schrieb Ezequiel Garcia <ezequiel at collabora.com>:
> On Mon, 2019-05-13 at 18:14 +0200, H. Nikolaus Schaller wrote:
>> Hi Mathieu,
>>> Am 10.05.2019 um 08:08 schrieb Mathieu Malaterre <malat at debian.org>:
>>>> The 4.19 kernel is stuck with
>>>> [    0.968637] Waiting for root device /dev/mmcblk0p1...
>>>> although the mmc driver is loaded:
>>>> [    0.760598] jz4740-mmc 13460000.mmc: JZ SD/MMC card driver registered
>>>> [    0.767091] jz4740-mmc 13460000.mmc: Using DMA, 4-bit mode
>>>> Before I start a bisect to find which patch between 4.19 and 5.0 made it
>>>> work, I better ask the CI20 specialists here first...
>>> https://patchwork.kernel.org/project/linux-mmc/list/?submitter=179601
>> Thanks for pointing to this patch set!
>> Unless I have missed something, all patches except the first one have been
>> backported to stable v4.19.40 so they should be effective. And the first one
>> doesn't seem to improve anything in my tests.
>> I have tried to git bisect and manual bisect and git log arch/mips/ingenic
>> but didn't find something in the jz47xx code or CI20 drivers that is obviously
>> related.
>> What I also tried is to cherry-pick the jz4780 dma changes introduced by
>> 4.20 - but also no success.  So it might be a side-effect of some other driver.
>> Current status of my tests is that
>> v4.20-rc2	boots to login:
>> v4.20-rc1	kernel panics with page faults and strange things
>> v4.19.0		fails with "waiting for root device"
>> same for v4.18 and v4.14
>> Unfortunately, these kernel panics make it difficult to git bisect between
>> v4.19 and v4.20-rc2.
>> It also does not seem to make a difference if I use the ci20_defconfig
>> or my own (otherwise I could simply bisect the diff between both defconfigs).
>> Well, I could simply use 4.20-rc2 or later only, but v4.19 is currently the
>> latest longterm kernel. It is the base of our LetuxOS distribution, so I'd
>> prefer to get it working.
>> Therefore, I am a little lost in pinpointing the reason why I can't get any
>> v4.19.x kernel boot properly. Is there maybe a private v4.19.x tree that is
>> known to boot from SD card so that I could start comparisons?
> I must admit I don't have enough context here... what is the issue exactly?

[    0.968637] Waiting for root device /dev/mmcblk0p1...

and kernel hangs.

on CI20 board with kernel v4.19.xx using ci20_defconfig

Works with v4.20 or later.

BR and thanks,

More information about the Letux-kernel mailing list