[Letux-kernel] Kernel v5.1-rc1 (was: LetuxOS Kernel v5.0-rc1)

Andreas Kemnade andreas at kemnade.info
Thu Mar 21 07:18:50 CET 2019


On Thu, 21 Mar 2019 07:05:18 +0100
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:

> HI,
> 
> > Am 20.03.2019 um 16:31 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> > 
> > Hi,
> >   
> >> Am 20.03.2019 um 08:30 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> >> 
> >> Hi,
> >>   
> >>> Am 20.03.2019 um 08:19 schrieb Andreas Kemnade <andreas at kemnade.info>:
> >>> 
> >>> Hi,
> >>> 
> >>> 
> >>> On Tue, 19 Mar 2019 13:30:17 +0100
> >>> "H. Nikolaus Schaller" <hns at goldelico.com> wrote:
> >>>   
> >>>>> Am 19.03.2019 um 13:16 schrieb H. Nikolaus Schaller <hns at goldelico.com>:  
> >>   
> >>>>>>> * GTA04A4:	backlight ok, display shows white pixels only    
> >>>>>> 
> >>>>>> hmm, did a quick test with mainline: older dtb + 5.1-rc1 kernel = display ok
> >>>>>> 5.1-rc1 kernel + dtb-5-1-rc1 (both mainline) = black screen    
> >> 
> >> Ah, I didn't read precisely: "black screen". I get this as well if I eliminate
> >> most Letux patch sets.
> >> 
> >> This means that one or two hacks are not yet upstream...
> >>   
> >>>>>   
> >>> well,
> >>> echo 0 >/sys/class/backlight/backlight/bl_power
> >>> resolved that. Then I had a working display with mainline 5.1-rc1 + dtb-5.1-rc1
> >>> 
> >>> I think we are talking about different problems.  
> >> 
> >> Looks so...
> >> 
> >> My main symptom is that I get a /dev/fb0, X server process is running, backlight
> >> is on, but the screen is completely white. And xset dpms force on/off can
> >> turn backlight on&off. But still only white pixels.  
> 
> I have now checked and the symptoms are two facets of the same problem.
> 
> When doing my git bisect of linus/master plus adding only 4 of our letux patches,
> I get a black display in the error case which goes completely white when echoing to
> bp_power.
> 
> I never had the backlight staying black but display working.
> 
> But there remains some difference by adding the full letux patch set. I.e. some
> piece of code does have the same side effect as echo 0 >/sys/class/backlight/backlight/bl_power
> 

Well, if I do that on mainline, I get a working display. Not only black screen.

So we probably have 
a) some initilalisation race condition

or 

b) some memory corruption.

Both are nasty.

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/letux-kernel/attachments/20190321/7e2d80ab/attachment.asc>


More information about the Letux-kernel mailing list