[Letux-kernel] Modem disappears GTA04A4

Jake jake42 at rommelwood.de
Fri Jan 25 20:52:46 CET 2019


On Fri, 2019-01-25 at 07:04 +0100, Andreas Kemnade wrote:
> On Sun, 20 Jan 2019 21:29:39 +0100
> Andreas Kemnade <andreas at kemnade.info> wrote:
> 
> > On Sun, 13 Jan 2019 23:28:35 +0100
> > Jake <jake42 at rommelwood.de> wrote:
> > 
> > > Hi,
> > > 
> > > I'm experiencing a problem with the modem disappearing on GTA04.
> > > For example when writing text messages to and fro with suspends
> > > in
> > > between it happens at times, that the modem /dev/ttyHS* files
> > > disappear. The modem is still unblocked in rfkill. 
> > > 
> > > I don't have any logs yet. I usually powered off the GTA04A4,
> > > removed
> > > the battery for a few seconds, reinserted and booted again to
> > > continue
> > > the conversation as soon as possible.
> > > 
> > > How can I toggle the gpio 186? to reenable the modem manually?
> > > 
> > > My observations so far:
> > > 4.19-rc7: modem disappears sporadically
> > > 4.19.12: modem disappears sporadically
> > > 4.20: does not wake on incoming call/text  
> > 
> > can reproduce this. The corresponding event device works, but
> > wakeup 
> > does not work. Ruled out: dtb changes. Will do further research.
> > 
> 
> does
> devmem2 0x48002A1A h 0x4104
> 
> help also for you? Just execute it after every boot. For me it helps
> with 4.20,
> but no idea why it is needed now.
Helping against modem disappearing or not waking on incoming call?
After my mails on modem disappearing, it didn't happen again yet.
Uptime is 13 days.

> Regards,
> Andreas

Thanks,
Jakob


More information about the Letux-kernel mailing list