[Letux-kernel] Modem disappears GTA04A4

Andreas Kemnade andreas at kemnade.info
Mon Jan 14 06:57:55 CET 2019


Hi,

On Mon, 14 Jan 2019 06:33:23 +0100
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:

> Hi,
> 
> > Am 13.01.2019 um 23:28 schrieb Jake <jake42 at rommelwood.de>:
> > 
> > Hi,
> > 
> > I'm experiencing a problem with the modem disappearing on GTA04.
> > For example when writing text messages to and fro with suspends in
> > between it happens at times, that the modem /dev/ttyHS* files
> > disappear.  
> 
> That is a known bug [1] in the modem firmware but unfortunately we
> did never get a better one.
> 
That might not be the modem itself. I remember also situation where that
was a problem with ehci.

> > The modem is still unblocked in rfkill. 
> > 
> > I don't have any logs yet. I usually powered off the GTA04A4, removed
> > the battery for a few seconds, reinserted and booted again to continue
> > the conversation as soon as possible.
> > 
> > How can I toggle the gpio 186? to reenable the modem manually?  
> 
To work around also ehci problems, also a
rmmod ehci-omap
modprobe ehci-omap

> "rfkill block wwan; sleep 0.5; rfkill unblock wwan" should do it.
> 
> > 
> > My observations so far:
> > 4.19-rc7: modem disappears sporadically
> > 4.19.12: modem disappears sporadically
> > 4.20: does not wake on incoming call/text

Not checked that yet on that kernel.

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/letux-kernel/attachments/20190114/f6ed513f/attachment.asc>


More information about the Letux-kernel mailing list