[Letux-kernel] letux 5.4 +pyra

H. Nikolaus Schaller hns at goldelico.com
Tue Dec 24 09:35:49 CET 2019


Hi Andreas,

> Am 23.12.2019 um 16:26 schrieb Andreas Kemnade <andreas at kemnade.info>:
> 
> On Tue, 17 Dec 2019 22:29:42 +0100
> "H. Nikolaus Schaller" <hns at goldelico.com> wrote:
> 
>>> Am 17.12.2019 um 21:39 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>>> 
>>> 
>>>> Am 07.12.2019 um 23:06 schrieb Andreas Kemnade <andreas at kemnade.info>:
>>>> 
>>>> Hi,
>>>> 
>>>> I get this on the pyra. Is it just me or is there really something
>>>> rotten with pyra and 5.4?  
>>> 
>>> I now have got almost the same with 5.5-rc2. Hadn't tested yet on Pyra.
>>> 
>>> So there is something broken already in 5.4. Seems to be related to
>>> serial_omap and/or hwmods.
>>> 
>>> Have to compare once again omap2plus_defconfig with letux_defconfig...  
>> 
>> even binaries of 5.3 do no longer boot.
>> 
>> What I suspect is that there is the wrong device tree. And I have done
>> a cleanup of the device tree files recently - maybe around 5.4.
>> 
>> Unfortunatley there was a mistake in the version encoding resistors
>> so that some different boards do report the same version code.
>> This breaks the automatic switch between all device tree files.
>> 
>> It affects only 3 or 4 prototypes and I have one of these...
>> Maybe yours is also affected.
>> 
>> So what .dtb does u-boot report?
>> 
> U-Boot 2016.11-00295-gba585a4 (Sep 21 2018 - 15:39:55 +0200)
> 
> LPAE build running in hypervisor mode!
> CPU  : ARM Cortex-A15 r2p2
> SoC  : OMAP5432-GP ES2.0
> Board: Pyra with Letux Cortex 15
> I2C:   ready
> DRAM:  2 GiB
> Reset:  peripherals
> MMC:   Found LC15 V5.1
> board_mmc_init called (vers = 51)
> U-Boot
> soft: gpio82 = 0 (mmc1=eMMC)
> OMAP SD/MMC: 0, OMAP SD/MMC: 1, OMAP SD/MMC: 2
> *** Warning - bad CRC, using default environment
> 
> Found Pyra MB V5.1
> Device Tree: omap5-letux-cortex15-v5.1+pyra-v5.1.dtb

yes, that is the problematic early prototype version...
Just

cp omap5-letux-cortex15-v5.1+pyra-v5.1.2.dtb omap5-letux-cortex15-v5.1+pyra-v5.1.dtb

and it should work again.

> SCSI:  SATA link 0 timeout.
> AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
> flags: 64bit ncq stag pm led clo only pmp pio slum part ccc apst 
> scanning bus for devices...
> 
> Regards,
> Andreas
> _______________________________________________
> http://projects.goldelico.com/p/gta04-kernel/
> Letux-kernel mailing list
> Letux-kernel at openphoenux.org
> http://lists.goldelico.com/mailman/listinfo.cgi/letux-kernel



More information about the Letux-kernel mailing list