[Letux-kernel] LetuxOS: kernel: letux-5.5-rc1

H. Nikolaus Schaller hns at goldelico.com
Thu Dec 12 19:07:59 CET 2019


> Am 12.12.2019 um 16:27 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> 
> Yes, looks like I did a mistake with my initial attempt.
> 
> Now the GTA04 boots - but still without display. Anyways,
> I now can finally analyse that.
> 

Well, good news: the GTA04 display *is* working :)

Only the framebuffer emulation isn't. So there is no console, blinking cursor or login:
unless you run X11 or something else. Or try the SGX demo.

/dev/fb0 exists.

But if I run the tiler-ctl script (which reinitializes the framebuffer) I get
a console visible for a short moment. After 1 second it disappears and the log
says something about fbcon_rotate_hint=0

I have never seen that before.

root at letux:~# ./tiler-ctl 0
0 -> 1
[  198.600585] Console: switching to colour dummy device 80x30
modprobe: FATAL: Module drm_kms_helper is in use.
[  198.737579] omapdrm omapdrm.0: DMM not available, disable DMM support
[  198.753021] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[  198.767486] [drm] No driver support for vblank timestamp query.
[  198.778015] drm_setup_crtcs_fb: sw_rotations=1
[  198.782714] drm_setup_crtcs_fb: fbcon_rotate_hint=0
[  198.829956] dmtimer posted=0
[  198.830566] Console: switching to colour frame buffer device 80x30
[  198.862823] omapdrm omapdrm.0: fb0: omapdrmdrmfb frame buffer device
[  198.907073] [drm] Initialized omapdrm 1.0.0 20110917 for omapdrm.0 on minor 1
root at letux:~# [  199.929534] drm_setup_crtcs_fb: fbcon_rotate_hint=0
[  199.947265] dmtimer posted=0

BR,
Nikolaus



More information about the Letux-kernel mailing list