[Letux-kernel] [BUG/PATCH 0/4] gpiolib: fix issues with legacy spi-cs-high handling

H. Nikolaus Schaller hns at goldelico.com
Mon Apr 1 18:59:22 CEST 2019


Hi all,

> Am 31.03.2019 um 12:07 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> 
> 2018-07-25 07:55:28: 
> 
> H. Nikolaus Schaller (4):
>  DTS: GTA04: SPI / gpiolib: work around a regression that unhides a
>    broken legacy handler, which makes the gta04 display inoperable
>  REVERT: DTS: GTA04: SPI / gpiolib: no no no, we do not want to "fix"
>    our device tree file
>  gpiolib: make legacy handling for spi-cs-high optional
>  gpiolib: spi-cs-high is checking the wrong node (the controller and
>    not the SPI slave device)
> 
> drivers/gpio/Kconfig      | 8 ++++++++
> drivers/gpio/gpiolib-of.c | 8 +++++---
> 2 files changed, 13 insertions(+), 3 deletions(-)
> 
> -- 
> 2.19.1
> 

I learned just some minutes ago that a new patch for gpiolib
came through 5.1-rc3 which does fix this in almost the same way
as I proposed.

Except that it seems to check for "cs-gpios" and then disable the
legacy handling.

So we do not need to add a config option for this legacy
handling (although I'd prefer to have it anyways to remove
some dead code).

Summary: this series can now be ignored.

BR and thanks,
Nikolaus



More information about the Letux-kernel mailing list