[Letux-kernel] Letux OS: Kernel 4.19-rc4

Michael Mrozek EvilDragon at openpandora.org
Thu Sep 20 00:46:47 CEST 2018


On Mi, 2018-09-19 at 11:03 +0200, H. Nikolaus Schaller wrote:

Well, I'm a bit confused myself here, so maybe aTc can shed some light
here.

Here's what I know:

The Pyra uses a Debian-Base OS with Pyra-specific addons (as packages).

The source for the packages can be found on 
https://dev.pyra-handheld.com

As far as I am aware, aTc uses the Letux kernel with a few patches and
a different config... but I have no idea where these are available :/

There is also a linux-image GIT... but that seems outdated, so I don't
think it's this he's using:
https://dev.pyra-handheld.com/packages/linux-image-pyra

There's also a U-Boot source, but I'm not sure this is exactly what aTc
uses:
https://dev.pyra-handheld.com/notaz/pyra-u-boot

Maybe he can let us know :)

> >  https://dev.pyra-handheld.com (requires an account?)
> 
> I don't use this resource. I think it is for user-space PyraOS, but
> someone else should comment on this.

It's mainly for everything related to the Pyra OS, yes.
It should contain everything needed to recreate the Debian incl.
bootloader and the kernel from scratch.

All packages are there, but it seems the kernel and U-Boot are mising.
aTc: Any reason you can't push the kernel / U-Boot sources you're
compiling to git?

The GIT doesn't need an account - unless you want to push updates.
Simply click on "Explore" at the bottom and choose "All" to see all
public projects on the GIT.

> So some source of confusion is that low level development (U-Boot,
> Kernel) is part of the LetuxOS project but what the user sees
> (PyraOS) is a separate project that cherry-picks some parts of
> LetuxOS.

To my knowledge, we would use the complete Letux kernel if it
fullfilled everything we need (dbp needs aufs in the kernel, which
isn't included).

> For example the TILER did work up to 4.18.x but is broken since
> 4.19-rc1. There was some manual rebase conflict resolution involved,
> so it might be a bug introduced by that. Or it might be a new API
> mismatch.

Was it really working or simply not complaining when compiling?

Because with the PyraOS, rotation worked fine with Kernel 4.15, but
with 4.18, the framebuffer showed a black picture as soon as we enabled
TILER rotation.

Without rotation, the framebuffer worked.


-- 
Mit freundlichen Grüßen,

Michael Mrozek

-----------------------
OpenPandora GmbH
Geschäftsführer: Michael Mrozek

Schäffbräustr. 11
85049 Ingolstadt
Deutschland
Tel.: 0841 / 990 5548
http://www.openpandora.de/
HRB 4879, Amtsgericht Ingolstadt
-----------------------
eMail: mrozek at openpandora.org



More information about the Letux-kernel mailing list