[Letux-kernel] AESS driver

H. Nikolaus Schaller hns at goldelico.com
Wed Jul 4 10:51:23 CEST 2018

Hi Marek,

> Am 03.07.2018 um 22:16 schrieb Belisko Marek <marek.belisko at gmail.com>:
> On Tue, Jul 3, 2018 at 10:13 PM Belisko Marek <marek.belisko at gmail.com> wrote:
>> Hi Nikolaus,
>> On Tue, Jul 3, 2018 at 10:10 PM H. Nikolaus Schaller <hns at goldelico.com> wrote:
>>>> Am 03.07.2018 um 22:04 schrieb Belisko Marek <marek.belisko at gmail.com>:
>>>> Hi Nikolaus,
>>>> On Tue, Jul 3, 2018 at 9:52 PM H. Nikolaus Schaller <hns at goldelico.com> wrote:
>>>>> Hi Marek,
>>>>>> Am 29.06.2018 um 09:15 schrieb Belisko Marek <marek.belisko at gmail.com>:
>>>>>> Hi Michael,
>>>>>> hmm strange but good that it works for you. I'll try to load driver
>>>>>> with this firmware. I'll share results then.
>>>>> I now tried to build a kernel with AESS driver, but it failed.
>>>>> The reason seems that some functions have been renamed in 4.18-rc1ff
>>>>> Mainly codec -> component.
>>>>> In this case snd_soc_component_to_platform(component) has gone...
>>>>> So it looks like we have to upgrade
>>>>> http://git.goldelico.com/?p=letux-kernel.git;a=commit;h=bc840309edc035d822c34fc897324a11c3e571fb
>>>>> Which kernel did you try?
>>>> I tried with 4.17 version (I have pushed work/andrey/aess branch based
>>>> on that version)
>>> Ah, ok.
>>> So we must fix the version I have rebased letux-base = 4.18-rc3 and pushed back.

>>> Maybe can you push yours again as work-aess-4.17.3?
>> Done.


I have looked into what happened. First of all I did a wrong fixup of a merge
conflict so that I added code back to letux-4.18-rc1 which was removed upstream.
So the compiler stumbled about some missing functions.

But the bigger problem is that struct snd_soc_platform * has gone and is to
be replaced by struct snd_soc_component * and associated helper functions.

I have started to rework this (hopefully without breaking things), but it is
not complete (I just touched 3 or 4 files and not all relevant for aess) and
it still does not compile.

If you or anyone else on this list has more time than me, please can you try to fix the code?

Here are my patches (on top of v4.18-rc2):


> Looking at sound/soc/omap/aess it looks like we must add ti,omap4-aess
> property to dts + some resources to have it working.
> I think I overlooked in my previous test run.

Ah, yes, that is reasonable. Like GPU needs some DT records so that the
driver can access the real hardware.

This likely also answers a question what happens if we have the AESS driver
on an OMAP3 system... It will simply be ignored if it is not in DT.


More information about the Letux-kernel mailing list