[Letux-kernel] Strange problem with non-LPAE letux-4.20-rc kernels on 4GB Pyra only

H. Nikolaus Schaller hns at goldelico.com
Tue Dec 4 22:14:29 CET 2018


Hi,

> Am 04.12.2018 um 22:04 schrieb Andreas Kemnade <andreas at kemnade.info>:
> 
> On Tue, 4 Dec 2018 21:55:56 +0100
> "H. Nikolaus Schaller" <hns at goldelico.com> wrote:
> 
>> Hi,
>> for testing of some new patches I did compile some letux-4.20-rc5
>> in non-lpae mode and tried to boot on the 4GB Pyra.
>> 
>> Boot process ends with:
>> 
>> [    3.544616] input: user-button as /devices/platform/user-button/input/input0
>> [    3.555006] input: pyra-game-buttons as /devices/platform/pyra-game-buttons/input/input1
>> [    3.564689] input: pyra-lid-wakeup as /devices/platform/pyra-lid-wakeup/input/input2
>> [    3.575503] palmas-rtc 48070000.i2c:palmas at 48:rtc: setting system clock to 2000-01-02 10:57:35 UTC (946810655)
>> [    3.586006] sr_init: No PMIC hook to init smartreflex
>> [    3.592186] vmmcsdio_fixed: disabling
>> [    3.597267] ldo3: disabling
>> [    3.600850] ldo8: disabling
>> [    3.604153] modem_vbus_power: disabling
>> [    3.608201] otg_path: disabling
>> [    3.611513] ALSA device list:
>> [    3.614662]   No soundcards found.
>> [    3.618600] Waiting for root device PARTUUID=17b72d7a-02...
>> 
> AFAIK PARTUUID resolution is done by initrd normally?!

Are you sure?

> So I am
> wondering why it ever has worked.

Well, command line is (using a reformatted card, hence new UUID):

[    0.000000] Kernel command line: console= root=PARTUUID=c8a507cd-02 rw rootfstype=ext4 rootwait console=ttyO2,115200n8 vram=12M omapfb.vram=0:8M,1:4M omapfb.rotate_type=0 omapdss.def_disp=lcd rootwait twl4030_charger.allow_usb=1 log_buf_len=8M ignore_loglevel earlyprintk

> Was there somehow a duplicate root=
> parameter, so 4.19 took the one it can process?

Good question. But does it explain why reinstalling binary letux-4.20-rc1 fails now?

> 
> 
>> The PARTUUID claimed to be missing seems to be correct (read through a device with USB card reader):
>> 
>> root at letux:~# blkid
>> /dev/mmcblk0: PTUUID="10a12191" PTTYPE="dos"
>> /dev/mmcblk0p1: LABEL="rootfs" UUID="46b783c0-53e3-42fe-96c4-8a7eae14739e" TYPE="ext3" PARTUUID="10a12191-01"
>> /dev/sdb1: LABEL="boot" UUID="D707-1ABC" TYPE="vfat" PARTUUID="17b72d7a-01"
>> /dev/sdb2: LABEL="rootfs" UUID="bbe7f361-dfbc-4fb2-b8e0-a71f748c48d1" TYPE="ext3" PARTUUID="17b72d7a-02"
>> root at letux:~#
>> 
>> I can see this effect only for 4.20-rc kernels (rc1..rc5).
>> Not for 4.19.x kernels which boot fine from the identical u-boot and rootfs (I have only
>> swapped uImage, modules and dtbs).
>> 
> Well, the sdcard from you does not have that problem.

I didn't ever have this problem up to today...

So some magic is going on.

BR,
Nikolaus

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.goldelico.com/pipermail/letux-kernel/attachments/20181204/bacaf1ac/attachment.asc>


More information about the Letux-kernel mailing list