[Letux-kernel] Strange problem with non-LPAE letux-4.20-rc kernels on 4GB Pyra only

H. Nikolaus Schaller hns at goldelico.com
Tue Dec 4 21:55:56 CET 2018

for testing of some new patches I did compile some letux-4.20-rc5
in non-lpae mode and tried to boot on the 4GB Pyra.

Boot process ends with:

[    3.544616] input: user-button as /devices/platform/user-button/input/input0
[    3.555006] input: pyra-game-buttons as /devices/platform/pyra-game-buttons/input/input1
[    3.564689] input: pyra-lid-wakeup as /devices/platform/pyra-lid-wakeup/input/input2
[    3.575503] palmas-rtc 48070000.i2c:palmas at 48:rtc: setting system clock to 2000-01-02 10:57:35 UTC (946810655)
[    3.586006] sr_init: No PMIC hook to init smartreflex
[    3.592186] vmmcsdio_fixed: disabling
[    3.597267] ldo3: disabling
[    3.600850] ldo8: disabling
[    3.604153] modem_vbus_power: disabling
[    3.608201] otg_path: disabling
[    3.611513] ALSA device list:
[    3.614662]   No soundcards found.
[    3.618600] Waiting for root device PARTUUID=17b72d7a-02...

The PARTUUID claimed to be missing seems to be correct (read through a device with USB card reader):

root at letux:~# blkid
/dev/mmcblk0: PTUUID="10a12191" PTTYPE="dos"
/dev/mmcblk0p1: LABEL="rootfs" UUID="46b783c0-53e3-42fe-96c4-8a7eae14739e" TYPE="ext3" PARTUUID="10a12191-01"
/dev/sdb1: LABEL="boot" UUID="D707-1ABC" TYPE="vfat" PARTUUID="17b72d7a-01"
/dev/sdb2: LABEL="rootfs" UUID="bbe7f361-dfbc-4fb2-b8e0-a71f748c48d1" TYPE="ext3" PARTUUID="17b72d7a-02"
root at letux:~# 

I can see this effect only for 4.20-rc kernels (rc1..rc5).
Not for 4.19.x kernels which boot fine from the identical u-boot and rootfs (I have only
swapped uImage, modules and dtbs).

And more strngely the same kernel boots on an older 2GB Pyra.

I have also tried an LPAE build and it reports to have 4GB memory but doesn't boot either.

So this is a really weird effect. It appears as if the MMC does not come up on
this board with a 4.20 kernel but does with 4.19. Strange.

Before someone asks: Ihave reformatted a completely fresh SD card
with letux4.19.4 kernel and that one works. After copying 4.20-rc
it fails to find the rootfs.

Unfortunately this new bug stops me more from debugging the Pyra 
panel drivers and USB3-OTG... Sometimes hardware and kernel software
seem to emit repulsive gravity :)

Ideas, suggestions welcome!


PS: git bisect may be our friend... Or waiting until they have fixed ext4 problems
upstream? But Iam not sure if this is an ext4 problem at all.

More information about the Letux-kernel mailing list