[Letux-kernel] USB3-port on OMAP5432EVM

Roger Quadros rogerq at ti.com
Wed Feb 8 12:48:38 CET 2017


Hi,

On 07/02/17 02:23, Tony Lindgren wrote:
> Hi,
> 
> * H. Nikolaus Schaller <hns at goldelico.com> [170205 03:34]:
>> fixed a type in the subject...
>>
>>> Am 05.02.2017 um 12:31 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>>>
>>> Hi Tony,
>>> does the usb(3) port still work with recent kernels?
>>>
>>> I noticed problems with 10.4-rc5 but found
>>> that 4.9.4 is also not working while 4.8.11 works.
>>>
>>> The symptoms/differences I see on my system are
>>> * no console log message that vbus is plugged in
>>> * no message that g_ether is configured
>>> * no usb0 in ifconfig -a
>>> * PC does not enumerate a device (even in usb2 speed)
>>>
>>> Before I dig into our defconfig: does it work for you
>>> with recent kernels or is there a known bug/patch/workaround?
> 
> Yeah so it seems, I just gave it a quick test with Linux
> next and nothing happens with dwc3.
> 
> Roger, do you have any ideas why dwc3 no longer works on
> omap5-uevm?
> 

I just tested it with v4.10-rc5 and linux-next-20170208.
It worked fine for me using omap2plus_defconfig.
Both super-speed and high-speed worked fine.

g_ether is not enabled in omap2plus_defconfig so you will have
to enable it manually.
CONFIG_USB_ETH=m
CONFIG_USB_ETH_RNDIS=y

Are you sure you loaded g_ether?
Does it show in lsmod?

cheers,
-roger


More information about the Letux-kernel mailing list