[Gta04-owner] [Letux-kernel] LetuxOS: Replicant for GTA04

H. Nikolaus Schaller hns at goldelico.com
Wed Nov 4 20:24:07 CET 2020


Hi all,
I am happy to announce that I was able to pushed that all a little more forward.

> Am 30.10.2020 um 17:22 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> 
> Hi all,
> here is an update with the latest kernels:
> 
> letux-4.14.203-replicant
> 	- works quite well incl. WiFi
> 	- touch screen precalib not optimal (at least on the unit I have tested with)
> 	- kernel has iio disabled
> 	- sound does not seem to work
> 	- Fdroid seems to be empty (maybe it is no longer compatible to the infrastructure)
> 
> letux-4.19.153-replicant
> 	- shows "ANDROID"
> 	- does not show Replicant robot
> 	- then gets problems with failed binder ioctl() and decides to do an automatic reboot

Now works as well. I did not test it deeply so there may be more bugs behind the scenes.

The key problem was that the 32 bit binder protocol used by our Android 4.2 was removed in
mainline starting with Kernel v4.18. Fortunately it was no problem to revert this (up to v5.10-rc2 so far).

Another smaller issue was how we enforce the framebuffer pixel format to RGB565. This was
not compatible to the way it was done in earlier kernels.

> 
> letux-5.4.73-replicant
> 	- binder: 1739:1739 transaction failed 29201/-22, size 120-4 line 3224;
> 	- [    7.288940] WARNING: CPU: 0 PID: 1043 at drivers/gpu/drm/drm_fourcc.c:305 drm_format_info+0x24/0x30 [drm]
> 	- on second attempt to bring up drm:
> 	  unable to handle kernel paging request at virtual address ffffffea - in drm_framebuffer_remove() aus omap_fbdev_init()
> 	- kernel panic

After applying all the same patches as for 4.19 the GTA04 shows "ANDROID" but does not show the Replicant robot.
There are a lot of warnings on the console but no automatic reboot.
So this has to be analysed further. And it can be analysed much better than with a system that kernel panics
20 seconds after power on.

> 
> letux-5.9.2-replicant
> 	- [    3.705841] WARNING: CPU: 0 PID: 0 at kernel/rcu/tree.c:2489 rcu_core+0x460/0x4e4
> 	- [    4.018096]   No soundcards found.
> 	- simply hangs - no console, no reaction, no kernel panic, no reboot


Applying all the same patches as for 4.19 has removed the rcu_core warning. Now it hangs a little later after "Run /sbin/init as init process".
So this is a different blocking point than with 5.4.

> 
> The most problematic thing seems to be the binder. Other issues may be missing/not yet loaded kernel modules.

The binder problem has been fixed and kernel modules were less a problem than initially assumed.

So I think this idea of revitalizing the GTA04 with Android is on a good track.

BR,
Nikolaus

> 
> BR,
> Nikolaus
> 
> 
>> Am 25.10.2020 um 20:01 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>> 
>> Hi,
>> breakthrough.
>> 
>>> Am 25.10.2020 um 19:02 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>>> 
>>> 
>>>> Am 25.10.2020 um 18:13 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>>>> 
>>>> And it will become interesting if 4.14 also works.
>>> 
>>> A quick test shows that it also boots if I remove modules.dep.bb during boot.
>>> 
>> 
>> I have found a fix for the replicant-modules script.
>> 
>> There were two issues:
>> * modules and symbols are matched after translating hyphens to underscore
>> * the modules.symbols file was not scanned
>> 
>> Now a fresh kernel build can be patched/installed and will even boot much
>> faster (since there is no need to run depmod or wait for modules).
>> 
>> So I can integrate this into the next releases (likely coming tomorrow).
>> 
>> BR,
>> Nikolaus
>> 
>> _______________________________________________
>> https://projects.goldelico.com/p/gta04-kernel/
>> Letux-kernel mailing list
>> Letux-kernel at openphoenux.org
>> http://lists.goldelico.com/mailman/listinfo.cgi/letux-kernel
> 



More information about the Gta04-owner mailing list