[Gta04-owner] Qtmoko on GTA04: the good, issues and some questions

cnut cnut at posteo.de
Tue Mar 20 00:25:38 CET 2018


since some days I am using my GTA04 with the new QtMoko. This post 
describes my findings as a user and maybe someone can provide answer 
some of my questions.

The installation:
makesd was downloaded and configured for my sd card reader/writer device.
The sd card reader was equipped with an empty sd card (without any 
partitions and without any file system). The installation was as easy as:
   ./makesd gta04 -r qtmoko
It created the partitions, the file systems and installed the Wheezy 
version of QtMoko on the sd card.

The first time I started the GTA04 with the QtMoko sd card inside, I was 
holding the aux button when inserting the battery. This led to the boot 
menu, where I started QtMoko by choosing "SD:1". Afterwards, it was 
enough to just use the power button for starting QtMoko.

The good stuff:
- PIN entry works, mobile provider is found within seconds, sound 
quality of the calls is fine
- Switching back between earpiece and speaker during calls works
- Even when travelling in a fast riding train with lots of cell 
switching, the phone ran well
- Battery life is better that than the "old" QtMoko versions some years ago

The issues:

Charging the GTA04 via the original OpenMoko power supply did not work: 
I tried it for 30 minutes when it was powered on and later when it was 
powered down. In both cases the energy symbol showed after a fresh 
reboot less power (and no charging battery animation). The same power 
supply charged the same battery in a GTA02 afterwards.
Using an USB cable connected to a powered on computer, does charge the 

I was not able to change the audio volume during calls. My assumption is 
that the neotool has to be used for this. But I am not able to move the 
slider there.
My workaround was to ssh in the GTA04, start alsamixer, do a call, set 
the alsamixer values and save these befor hanging up.

No sound when using cable headsets. I tried 2 different headsets which 
fitted both in the audio jack.

Wireless lan was not checked by me. Activating bluetooth via UI seems 
not to be possible. I did not invest time in both (because I do not need 

The "Backup Settings" in the Settings menu does nothing. Because I am 
backing my stuff via ssh, I do not need it.

After booting, sometimes I was not able to make a call and the screen 
showed a message "can`t find modem". Maybe a physical not-so-well-fixed 
sim card was the issue.

It would be cool if the debian package sqlite3 would be included (116 
kByte of archives), because you can then delete all contacts using ssh 

Some questions:

As in older QtMoko versions, sometimes all contacts are copied to the 
sim card. Is there a way to prevent this?

Is there a way to delete the contacts on a sim card using a bash script 
when the sim card is inserted in a GTA04?

I sometimes have the need to block a single number (call barring or 
automatically hang up for a single number). Is this possible?
If anybody has an idea how to do this e. g. using a script, please let 
me know.

When being in a phone number field (e. g. when adding a contact) the 
standard keyboard is shown. I would love to have just a keyboard with 
big phone numbers. Is there already such a keyboard?

The Logging has quite some entries like "unkown mouse event type=3, 
code=18, value = ...". Is this an issue?

QtMoko on the GTA04 is really cool:

Since 9 years I am using a GTA02/Freerunner as my only private phone. In 
the last years I am trying to find a usable as-open-as-possible 
replacement with a standard Linux. My current impression ist that QtMoko 
and GTA04 fills this gap.
For a lot of tasks it is fast enough to use it as a standard Debian 
linux computer.

Hats off to all the hardware and software devs!


More information about the Gta04-owner mailing list