[Gta04-owner] Openmoke charger detection

Andreas Kemnade andreas at kemnade.info
Sat Dec 29 22:14:13 CET 2018


Hi,

On Sat, 29 Dec 2018 17:36:18 +0100
Andreas Kemnade <andreas at kemnade.info> wrote:

> Hi,
> 
> I heard reports there that some people have usb problems if the
> gta04 is booted with usb cable attached, so the cable needs to be
> re-attached. I do not have the trouble.
> Before doing more research, one thing comes to my mind. The id pin
> status check. I have disabled it in my systems because I do not have an
> openmoke charger anymore. I think I have forgotten it on some trip.
> If the id status pin check is done during probing, I am quite sure
> that there is a race condition that under some circumstances triggers.
> 
> What I am wondering here is: Are people still using the om charger so
> that it is something worth fixing? Or is it simply enough to disable
> the om charger check in the udev rules.
> 
> I will probably try to use a fresh, plain letux system and try to
> reproduce problems there. The id pin status check was just something 
> coming to my mind. If there is a race condition involved I might also
> be just on the lucky side.
> 
ok, fresh letux-lxde + letux-4.20:
poweron->wait->ssh via usb->shutdown -h 0->wait till off

a dozen times. USB was connected all the time. No problems. So perhaps
not the charger detection.

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20181229/e7dbbbe1/attachment.asc>


More information about the Gta04-owner mailing list