[Gta04-owner] GTA04A5 charging?

H. Nikolaus Schaller hns at goldelico.com
Thu Jul 13 16:44:20 CEST 2017

> Am 13.07.2017 um 14:28 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> Am 13.07.2017 um 06:33 schrieb H. Nikolaus Schaller <hns at goldelico.com <mailto:hns at goldelico.com>>:
> Hi Rainer,
>> Am 12.07.2017 um 16:58 schrieb Rainer Blome <rainer.blome at gmx.de <mailto:rainer.blome at gmx.de>>:
>> This issue comes up so often that I wonder if anything can be done to fundamentally avoid it. 
>> The auto-boot voltage level should be high enough so that full boot is likely to succeed before the boot process itself drops voltage to the power-off level, no? Sounds like the level at which the system auto-boots is currently too low, at least for some batteries.
>> Can the auto-boot voltage level be changed?
> No. Or well, it can * after* the first successful boot. But it is reset to hardware defaults after removing the battery.
>> Another avenue might be a separate OS instance that boots fast enough, 
>> dedicated to charging only. Many Android systems use this technique, and successfully so, it seems to me.
> There is indeed a known trick: switch the charger to 500mA capability in U-Boot (or even MLO), i.e. within the first 5 seconds.
> Then, the GTA04 can run continuously from USB charger (drawing ca. 400mA from the 500mA provided).
> We even have some disabled fragment sitting in our U-Boot and an issue report for this:
> http://projects.goldelico.com/p/gta04-xloader/issues/279/ <http://projects.goldelico.com/p/gta04-xloader/issues/279/>
> http://git.goldelico.com/?p=gta04-uboot.git;a=blob;f=board/goldelico/letux-gta04/twl4030-additions.c;h=0d0c4f385b7d09ef63c4738ca15ed7fccd8617d6;hb=0c5e26e7886ea7d2d934f65e2e6cbf15a2b52bc8#l405 <http://git.goldelico.com/?p=gta04-uboot.git;a=blob;f=board/goldelico/letux-gta04/twl4030-additions.c;h=0d0c4f385b7d09ef63c4738ca15ed7fccd8617d6;hb=0c5e26e7886ea7d2d934f65e2e6cbf15a2b52bc8#l405>
> In earlier U-Boot/MLO we had another patch:
> http://git.goldelico.com/?p=gta04-xloader.git;a=blob;f=board/omap3530gta04/omap3530gta04.c;h=1d490c94ad11f5fdba1b3660cce340bde7fb6fa2;hb=HEAD#l112 <http://git.goldelico.com/?p=gta04-xloader.git;a=blob;f=board/omap3530gta04/omap3530gta04.c;h=1d490c94ad11f5fdba1b3660cce340bde7fb6fa2;hb=HEAD#l112>
> But this was never worked out or tested. AFAIR it did *not* work as in the source code.
> And it needs someone who wants to write and debug a patch.

After some more research I found that we are already very close to a solution in our Letux U-Boot.

Andreas Kemnade had added a "charge" u-boot command a while ago.

GTA04 # charge    
charge: missing subcommand.
charge - battery charging sub-system

charge off - disable charging
auto - automatic charging
continuous - software-controlled charging

GTA04 # 

So we simply need to run "charge auto" or "charge continuous" at the beginning of the boot script.

Well, I have tried, but the "charge auto" command hangs. "charge cont" or "charge off" works.

Anyways, it just means to debug the "charge auto" command:




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20170713/102774ae/attachment.html>

More information about the Gta04-owner mailing list