[Gta04-owner] Bricked phone after uboot update failure

H. Nikolaus Schaller hns at goldelico.com
Mon Jul 10 08:19:41 CEST 2017

Hi Lionel,
since others may run into similar issues, I have forwarded to the mailing list.

> Am 09.07.2017 um 19:27 schrieb L.B. <lionel.broche at gmail.com>:
> Hi Nikolaus,
> Thanks for the fast answer.
> I tried pushing the AUX switch while inserting the battery but the phone remains inactive even though that was with the sdcard that I have used so far.

Hm. Does no LED light up? Or does some LED blink or stay red?
If not it looks more like a drained battery.

I have tried the following:

1) use fresh SD card (available as /dev/sdb on my system)

umount /dev/sdb*
wget -O - http://download.goldelico.com/gta04-main/production/20150318-gta04.dd.bz2 | bunzip2 >/dev/sdb

2) boot with this card (pressing AUX)
The power LED should blink red/green while flashing is being done.
This installs back the "old style" U-Boot.

3) I had to repeat 2 or 3 times to be able to boot the kernel completely from the SD card

4) Boot another SD card with latest boot system created by

DEV=/dev/sdb ./makesd gta04

This installs the "new style" U-Boot system in NAND flash.

5) this also needed 2 or 3 repeats
Maybe it has to shake up things in U-Boot environment in NAND until everything fits.

6) then I could boot an SD card without MLO/U-Boot partition.

Note that it is not possible to boot from NAND only at this stage. One has to run /root/flash-nand
(e.g. through ssd root at over USB cable) to install the latest DT based kernel in NAND.

The reason is that the "old style" U-Boot does not take care of the DT in NAND like the new one does.
Both old and new style U-Boot can load a kernel from SD card.

> Unfortunately I do not have a serial cable.

It would be the best to find out what is going wrong.

> Is it something I can build myself or should I buy one?

It can be built yourself - provided you get the correct pre-crimped Molex pico-blade cable end (8 pins).

A description for soldering is in the manual http://projects.goldelico.com/p/gta04-main/downloads/47/
in section "6.3.2. Building a cable".

The cable should be similar to this one: http://www.molex.com/molex/products/datasheet.jsp?part=active/0151340803_CABLE_ASSEMBLIES.xml
except that we need only one end (but you can cut off the second connector).
Mouser and DigiKey (and others) seem to have them in stock: 538-15134-0803 / WM15275-ND

I think you can get also pre-crimped single wires and the plastic part of the socket:


You also need a DB9f socket (preferrably plus case) and likely an FTDI or Prolific RS232 to USB adapter.

Please note that the GTA04 has real RS232 interface levels and is not using a 3.3V or 5V UART port
like many other SBC.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20170710/0ae2c36e/attachment.html>

More information about the Gta04-owner mailing list