[Gta04-owner] QtMoko snapshot

tgrauss tgrauss at f-gp.eu
Fri Dec 29 20:52:15 CET 2017


Hi,

On Fri, 29 Dec 2017 19:42:34 +0100
Andreas Kemnade <andreas at kemnade.info> wrote:

> Hi,
> 
> On Fri, 29 Dec 2017 19:15:59 +0100
> tgrauss <tgrauss at f-gp.eu> wrote:
> 
> > Hi,
> > 
> > I tried to install a Debian to test the qtmoko package.
> > I have already installed the new U-boot successfully.
> > Now, I used the makesd script to recreate a new filesystem on the sd
> > card and unzipped the latest minimal debian root file system.  
> 
> = stretch or jessie?
it was stretch (latest-armhf-minimal.tbz)
I have used makesd gta04
I have then moved the content of the second partition to a temporary
folder. I have uncompressed the latest-armhf-minimal.tbz in the sd card
second partition then I have copied the lib/modules folder from the
temporary folder into the /lib directory in the partition.
I have then put the sd card in the phone and booted.
 
> > 
> > I tried booting this and the screen flashed red 2 times immediately
> > after inserting the battery, then a blinking cursor and nothing
> > else.  
> 
> Can you confirm that the sd card has no boot.scr. u-boot.img, etc on
> it? It looks like the bootloader was re-flashed again for some reason.
> Just blinking cursor might be ok for a minimal image, you should be
> able to login via ssh.
The sd card has a boot.scr,u-boot.img etc on the first partition.

> > Thinking about a problem with the debian system, I forced the phone
> > to turn off by pressing the power button for a long time.
> > 
> > After this, impossible to turn on the phone any more.
> >  
> = No reaction on the serial console, the screen and the leds? No
> difference with aux button pressed?
> 
No reaction anymore on the screen and button/leds. No reaction with
both buttons pressed either :(
There is nothing on the serial line also using the USB cable :(
I have also tried pserial using the JTAG cable like this : 
./pserial -p /dev/ttyUSB0 -f uart-monitor.bin
and it is waiting for the ASIC id and nothing happen...

I have charged the battery on an external charger just in case and
tried again without success.

> > I thought about a short circuit between the IR led and the screen
> > (happened before so I had to install a piece of plastic between
> > them. But it didn't move and I don't see where the problem might be.
> > 
> > I tried then to recreate the default sd card with makesd but nothing
> > happen any more on the phone.
> > 
> > Does someone have an idea?
> >   
> Do you have access to the serial console? Does it appear as usb device
> for a short time like this when you boot with aux key pressed? 
> 
> Dec 29 10:41:09 aktux kernel: [1136546.966614] usb 1-2: New USB
> device found, idVendor=0451, idProduct=d00e Dec 29 10:41:09 aktux
> kernel: [1136546.966621] usb 1-2: New USB device strings: Mfr=33,
> Product=37, SerialNumber=0 Dec 29 10:41:09 aktux kernel:
> [1136546.966625] usb 1-2: Product: OMAP3630 Dec 29 10:41:09 aktux
> kernel: [1136546.966629] usb 1-2: Manufacturer: Texas Instruments
> 
> Regards,
> Andreas

Regards

Thierry



More information about the Gta04-owner mailing list