[Gta04-owner] Progress GTA04 and Letux OS

Neil Jerram neil at ossau.homelinux.net
Thu Dec 28 19:21:01 CET 2017


Hi Nikolaus,

Thanks for the detailed instructions here.  I think they may have worked 
for me, but am not sure - please see more inline below...


On 19/12/17 19:40, H. Nikolaus Schaller wrote:
> Hi,
>
>> Am 19.12.2017 um 18:51 schrieb Neil Jerram <neil at ossau.homelinux.net>:
>>
>> On 19/12/17 09:57, H. Nikolaus Schaller wrote:
>>> What you should do: update your U-Boot in NAND.
>>>
>>> To do this, use makesd gta04 / makesd gta04a5 to format
>>> a "production image" SD card (dual partition). Insert
>>> into your GTA04, press the AUX button and insert the
>>> battery. This will flash the new U-Boot into NAND
>>> (red screen) and from that moment on you have this new
>>> feature in your U-Boot and can use the SD card for other
>>> things.
>> Please could give us a reference to more detailed instructions for doing this?  I'm sorry, it's a while now since I last worked on my GTA04, but I am very interested to get this improvement in place, so many thanks to you and Andreas.
> Ok, let's try (I hope I did not forget anything):
>
> 1. get an µSD card yo do not need otherwise with at least 2GB
> 2. plug into some SD card reader on a Linux host
>     a recent Debian or Ubuntu is recommended
>     It could even be the GTA04 if you manage to connect the SD reader through OTG and set up WLAN
>     I currently use the OMAP5432EVM with Letux-OS
> 3. find out which device name the SD card has (usually something like /dev/sdb)
> 4. follow instructions at http://projects.goldelico.com/p/gta04-makesd/
>
> 	wget -O makesd "http://git.goldelico.com/?p=gta04-makesd.git;a=blob_plain;hb=HEAD;f=makesd"
> 	chmod +x makesd
>
> 5. run (change /dev/sdb to your SD card reader if needed) as root
>
> 	DEV=/dev/sdb makesd gta04
>
>     or
>
> 	DEV=/dev/sdb makesd gta04a5
>
> 6. Insert µSD into your GTA04
> 7. press the AUX button and keep pressed
> 8. insert the battery (well, it should have been charged a little before)

OK, so I did up to here, but I think I might not have charged my GTA04 
enough first.  I believe I did see a red screen; but shortly later I 
think the phone ran out of power and died; certainly it did not get as 
far as showing the LXDE desktop.

Since then, I have left the phone plugged in (by a USB cable from my 
laptop) for a long time, with the same SD card in place.  It has booted 
to the LXDE desktop, and my SSHing in I can see that it now has a lot of 
charge:

root at letux:~# cat /sys/class/power_supply/bq27000-battery/uevent
POWER_SUPPLY_NAME=bq27000-battery
POWER_SUPPLY_STATUS=Not charging
POWER_SUPPLY_PRESENT=1
POWER_SUPPLY_VOLTAGE_NOW=4086000
POWER_SUPPLY_CURRENT_NOW=283815
POWER_SUPPLY_CAPACITY=93
POWER_SUPPLY_CAPACITY_LEVEL=Normal
POWER_SUPPLY_TEMP=284
POWER_SUPPLY_TIME_TO_EMPTY_NOW=15060
POWER_SUPPLY_TIME_TO_EMPTY_AVG=14160
POWER_SUPPLY_TECHNOLOGY=Li-ion
POWER_SUPPLY_CHARGE_FULL=1142582
POWER_SUPPLY_CHARGE_NOW=1066932
POWER_SUPPLY_CHARGE_FULL_DESIGN=1233792
POWER_SUPPLY_CYCLE_COUNT=89
POWER_SUPPLY_ENERGY_NOW=4108440
POWER_SUPPLY_POWER_AVG=1043900
POWER_SUPPLY_HEALTH=Good
POWER_SUPPLY_MANUFACTURER=Texas Instruments

Now, if I do the following procedure ...

- 'poweroff' (via SSH)
- remove USB cable
- remove battery
- keep AUX button held down
- replace battery

... I do not see any red screen.  Instead I see the partition order 
choice screen (with a blue/green pastoral background), and if I select 
the first button, the phone boots to LXDE.

Does the absence of a red screen mean that the flashing has previously 
succeeded?

Many thanks! - Neil

> 9. GTA04 should boot and the screen should turn red after some seconds
> 10. take out battery and install your old µSD card (if you had one)
> 11. boot as usual
> 12. wipe out the µSD for reflashing if you do not want to store it
>
> If anything fails, please cry for help :)
>
> BR and good luck,
> Nikolaus
>



More information about the Gta04-owner mailing list