[Gta04-owner] [Community] [Announce] Goldelico Replicant Testing Snapshot (2015.06)

Lukas Maerdian luk at slyon.de
Fri Jul 24 11:51:19 CEST 2015


Hi Adrien,

Am 18.07.2015 um 09:55 schrieb Adrien Dorsaz:
> Hi Lukas,
> 
> First of all, thanks for this new test release !
> 
> I've tried it last week and I've noticed during calls with my GTA04A4 my
> interlocutor don't hear anything. I'm sure that the issue don't come
> from my hardware, because it works well with QtMoko (except that the
> sound is a bit low for my interlocutor).
> 
> Do you know which filter I should use with `adb log` to have relevant
> logs during calls ?
> 
> A second point it that Android don't find every time my operator. I had
> to play with air plane mode / gps antenna to be able to connect my phone
> to the network (but when it connects, it seems to work well, even the
> 3G).

Both issues are known. But there doesn't seem to be anything interesting
in the adb logs, as stated by Christ already.

If you want to have a look though, you can grep for "TinyALSA", i.e.:
  adb logcat | grep TinyALSA

I did not see the connection problem on my own device, yet. But I have
logs from jake42 about it. Just a guess: Maybe it has to do with the
available signal strength...
I have to further investigate this issue.

> Otherwise, I had to make a new install of my destkop with Debian Jessie
> 64bit and then I've tried to compile your version of Replicant. But I
> wasn't able to build the bootimage because of clang linking errors (I've
> attached the logs). Did someone already seen such errors ? I've tried to
> look for them on the web, but I didn't find relevant results.
> 
> Thanks and best regards,
> Adrien
> 
> PS:
> I've followed the Replicant wiki to install the build dependencies [0],
> it has been updated recently, and I've followed the gta04 wiki to run
> the build.

I have not seen this before... Did you use Jessie before, too?
Otherwise, the Android build system might not be compatible with Jessie,
yet. Maybe you can find some kind of tutorial how to build (generic)
Android on Jessie..

Another thing you can try is this (I'm just guessing here):
https://sft.its.cern.ch/jira/browse/ROOT-4995

It is not related to Android, but they seem to have fixed a similar
problem by compiling with "make FORCELLVM=1"

Best,
  Lukas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20150724/92805222/attachment.asc>


More information about the Gta04-owner mailing list