[Gta04-owner] QtMoko & Kernel 3.19.0-gta04+ touchscreen issue

Dr. H. Nikolaus Schaller hns at goldelico.com
Tue Apr 21 15:39:39 CEST 2015


Am 21.04.2015 um 15:06 schrieb Sebastian Reinhardt <snr at lmv-hartmannsdorf.de>:

> Am 21.04.2015 um 10:01 schrieb Dr. H. Nikolaus Schaller:
>> Hi,
>> 
>> Am 20.04.2015 um 22:00 schrieb Sebastian Reinhardt <snr at lmv-hartmannsdorf.de>:
>> 
>>> Hi,
>>> I used my GTA04 with Kernel 3.7-neil-plus and Qtmoko (v57). Now I liked to make further experiments with bluetooth- headsets (esp. my freespeech headset in my motorcycle helmet).
>>> So I used the new "makesd" to create a new sdcard with kernel 3.19.0-gta04+. I flashed the phone (./flash_nand).
>>> This worked without serious issues (some messages about "man-files", no real issue, I guess).
>> Well, the 3.19 kernel is not yet ready for flashing to nand. But it works (almost) fine from SD card.
>> 
>> So you might consider to downgrade the flash_nand to 3.12 (but keep x-loader and u-boot by making a single-partition card). But if you don’t want to boot w/o SD card you can just wait a little until we have it mature (maybe with 4.1) and then flash that one.
>> 
>>> Now I created a "working" sd-card with QtMoko, by using "makesd". I can boot the phone. But I get the "QtExtended"- Splash screen, only.
>>> If I touch on scren ("Tap anythere on the screen to continue" is displayed), nothing happens.
>>> I am able to login via serial console (RS232). I also tried "depmod -a" and rebooted my phone, without any errors or changes....
>>> The "uname -a" on console says: "Linux gta04 3.19.0-gta04+ #992 SMP Mon Feb 9 09:04:09 CET 2015 armv7l GNU/Linux"
>>> What can I do? What was wrong? Is any thing changed "dramatically“?
>> What I suspect is that something has changed in touch event processing between 3.7 kernel and 3.19. It might be as simple as the touch screen device name /dev/input/touchscreen. Can you check if that file exists? If not, you can use the latest uenv rules from the kernel tree:
>> 
>> http://git.goldelico.com/?p=gta04-kernel.git;a=tree;f=GTA04/etc/udev/rules.d;h=7c4f77c06ad17d521c0b56f4210c6afa3e9075d3;hb=refs/heads/3.19.0
>> 
>> You probably should install them anyways since the charging system has changed and without these updated rules charging will not work (well).
>> 
>> Or you can change the QtMoko file name where it looks for the touch. I think there is also a debug mode for starting QtMoko from RS232 console and watch for messages.
>> 
>> BR,
>> Nikolaus
>> 
> 
> The touchscreen device node is present
> ---------------------------
> lrwxrwxrwx 1 root root      6 Jan  1 00:00 touchscreen -> event5
> —————————————

That looks good. Maybe QtMoko is just not looking for /dev/input/touchscreen.

> 
> There are several error messages about missing firmware and other … (see atttached textfile, if this list is accepting attachments..)

Most likely the WLAN firmware required for later kernels is missing in the QtMoko image.

> 
> What is the best choice for a working phone with QtMoko, actually (for next 1-1.5 year)?
> Kernel v3.12, v3.7-neil-plus or any other? I like to use phone, wlan, bluetooth, gps and camera….maybe wired headset....

Well, until we find out how to build QtMoko from scratch and upgrade/fix these things [1] on Debian Jessie,
the best solution is to use the v3.7-neil-plus kernel.

It supports all functions you mention except camera (which is only supported by the 3.12 kernel but power management is worse than with 3.7-neil-plus).

BR,
Nikolaus

[1]: http://projects.goldelico.com/p/gta04-qtmoko/



More information about the Gta04-owner mailing list