[Gta04-owner] [PATCH 2/3] ASoC: twl4030: allow voice port to be connected externally.

NeilBrown neilb at suse.de
Wed Nov 19 23:04:24 CET 2014


On Wed, 19 Nov 2014 11:00:09 +0100 "Dr. H. Nikolaus Schaller"
<hns at goldelico.com> wrote:

> Hi Neil,
> 
> Am 18.11.2014 um 03:56 schrieb NeilBrown <neilb at suse.de>:
> 
> > On Sun, 16 Nov 2014 19:00:42 +0100 "Dr. H. Nikolaus Schaller"
> > <hns at goldelico.com> wrote:

> > I'm hoping that does something useful.  Do we have docs that would confirm
> > that those messages  (0x82 and  0x81) do, or does anyone know enough about
> > the USB protocol to know more about that this might mean?
> 
> Unfortunately no. Not even in the under NDA docs I have. There appears to be
> some additional protocol to directly interface using packets.
> 
> And, even worse I did not see any effect when I tried (but my observations may
> not be reliable).

That's disappointing.  I might see if I can reproduce your results.


> 
> It could indeed work like you describe for wifi/sdio.
> 
> What I don’t like there will be also present: the device is powered up at boot
> time. Which is not good if the battery is nearly empty or has just started charging.

That is a real issue, but is quite broad - applying to Modem, wifi, sensors,
and possibly other components.

So I agree this is an important issue, but think it needs a system-wide
solution.
e.g. the system would initially be in a "low power" state and nothing is
turned on that isn't needed for monitoring or charging the battery.
Once the battery monitor determines that sufficient power is available it
flips the system wide state to "stable power" at which point other devices
are allowed to turn on.


> >> I am not sure where you did get the „gpio175" from?
> > 
> > In the GTA04A4 schematic, Sheet 10/20, near the middle of the top of the
> > sheet, it shows GPIO175 connected to a resistor/transistor network that I
> > don't understand.
> > GPIO186 is connected to the same network which connects to WWAN_RESET and
> > ON_KEY on the GTM601.
> 
> Ah, I see. This was intended to be a feedback to the CPU so that it can know if the
> modem is powered on. But it had wrong polarity. Therefore R1008 it is not installed
> on any device and therefore not mentioned elsewhere.

Ah, OK. I can ignore it then.  I suspected as much but wanted to be sure.

> 
> > 
> > In the GA04A3 schematic, Sheet 10/19 GPIO175 is connected directly to
> > HOST_WAKE_WWAN.
> 
> This was swapped with GPIO10 when moving from A3 to A4.
> 

GPIO176 on the A3 connects to 3G_WOE, and that was swapped to GPIO10 on the
A4.
GPIO175 connects to HOST_WAKE_WWAN and is the one I was asking about.
Presumably I can ignore that too, but I prefer to be certain.

Thanks,
NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 811 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20141120/6f7316bf/attachment.asc>


More information about the Gta04-owner mailing list