[Gta04-owner] Goldelico Replicant 4.2 with Wifi

Niels nift at maclisp.org
Sun Mar 16 20:59:45 CET 2014


Lukas Maerdian <luk at slyon.de> writes:

> 2014-03-16 11:59 GMT+01:00 Heinz Matusch <heinz.matusch at utanet.at>:
>> - battery symbol display shows "empty"
>
> Other people reported the same, but I cannot see this problem on any
> of my devices, so I can't debug it. Maybe someone who sees the problem
> can do some deeper research? Maybe the battery isn't correctly
> calibrated? Is it working on another distribution, whith the same
> kernel (e.g. 3.12)?

To add some more information. As previously reported the battery shows
"empty" for me on replicant, but works on qtmoko with this kernel:

root at neo:~# uname -a
Linux neo 3.7.0-gta04-qtmoko-v56 #1 PREEMPT Mon Jul 1 17:14:24 UTC 2013 armv7l GNU/Linux

And using this rootfs
http://download.goldelico.com/gta04/debian/20140103-wheezy-7.3-full.tbz
I get:

root at gta04:~# uname -a
Linux gta04 3.12.0-gta04 #239 PREEMPT Thu Jan 2 11:50:01 CET 2014 armv7l GNU/Linux
root at gta04:~# cat /sys/class/power_supply/bq27000-battery/uevent 
POWER_SUPPLY_NAME=bq27000-battery
POWER_SUPPLY_STATUS=Full
POWER_SUPPLY_PRESENT=1
POWER_SUPPLY_VOLTAGE_NOW=4188000
POWER_SUPPLY_CURRENT_NOW=-134410
POWER_SUPPLY_CAPACITY=100
POWER_SUPPLY_CAPACITY_LEVEL=Full
POWER_SUPPLY_TEMP=364
POWER_SUPPLY_TIME_TO_FULL_NOW=0
POWER_SUPPLY_TECHNOLOGY=Li-ion
POWER_SUPPLY_CHARGE_FULL=919453
POWER_SUPPLY_CHARGE_NOW=919453
POWER_SUPPLY_CHARGE_FULL_DESIGN=1233792
POWER_SUPPLY_CYCLE_COUNT=376
POWER_SUPPLY_ENERGY_NOW=3305440
POWER_SUPPLY_POWER_AVG=0
POWER_SUPPLY_HEALTH=Good


Niels


More information about the Gta04-owner mailing list