[Gta04-owner] Goldelico Replicant 4.2 with Wifi

Lukas Maerdian luk at slyon.de
Sat Mar 15 20:20:37 CET 2014


2014-03-15 13:04 GMT+01:00 Niels <nift at maclisp.org>:
>> I'm glad to announce a new Replicant 4.2 testing-release for the GTA04.
>> The binary, single partition image for your GTA04 can be found here:
>>   http://download.goldelico.com/gta04/replicant/4.2/20140313-WiFi-4.2/
>>
>> The big change since the last release, is that basic wifi support is
>> now integrated. Which means you can scan for and connect to available
>> networks via the UI (incl. getting an IP address via DHCP). This makes
>> the device quite a bit more usable for testers, as you can now surf
>> the web or manage your mails. Please note that the first time boot of
>> this system will take a bit longer as usual, as some one-time tasks
>> are executed.
>
> Hi, I tried downloading the makesd script from the above url. Ran the
> script, put the sdcard in my gta04 and booted replicant. So far so
> good.
>
> First thing I tried was to connect via wifi. But it did not work for
> me. If I try to turn on wifi with the wifi slider button it will say
> "on" for a while, but in a dark grey color (darker than the light grey
> on the other sliders on off). After ~30 seconds it will switch to off
> and stay dark gray. Tried with another sdcard, some reboots, and gave
> up after a while.
>
> I've only used qtmoko on my gta04 before, but I can't get wifi working
> there either. So maybe wifi is not working on my gta04. Is there a way
> to test or debug it?

If wifi isn't working in the other distirbutions either, it sounds
like there is something wrong with you wifi hardware.

> Also it reports 0% for the battery (which is the old gta02 battery)
> and have no indication of charging or decharging when connected to the
> original openmoko usb charger. (usb cable is recognised when
> connected, but not for charging).

That's strange, the battery indication should work. I had trouble when
using an old gta02 battery, as there was some green coating on the
middle pad, which disturbed the HDQ communication. Could you check the
state of your battery pads?
(http://lists.goldelico.com/pipermail/gta04-owner/2014-March/005431.html)

BR,
  Lukas


More information about the Gta04-owner mailing list