[Gta04-owner] Modem off

NeilBrown neilb at suse.de
Sun Sep 15 00:29:37 CEST 2013


On Sat, 14 Sep 2013 18:11:29 +0200 Radek Polak <psonek2 at seznam.cz> wrote:

> Hi,
> i wonder if modem powering off works as it should. Attached is charging graph 
> taken from my GTA04.
> 
> You can see power consumption for:
> 
> 1/ normal suspend 13:09 to 14:26, discharging current is 24mA
> 
> 2/ suspend when modem was turned off as documented here [1] from 14:32 to 
> 16:11, discharging current is 37mA
> 
> 3/ device turned off with modem turned off from 16:11 to 16:59, discharging 
> current is 14mA
> 
> What is strange - i'd expect current at 2/ to be under 24mA and it should tell 
> us how much modem eats.

Clearly the modem actually generates current (harvested from the air waves)
and when you turn it off, you no longer benefit from that :-)

I've noticed this too.  I blame the USB interface.  I'm not really sure why,
but my current theory is that is it the source of all our problems.

I've found that if I hold the reset line of the USB transceiver down so the
chip stays in reset, something eats even more power.

I'm wondering if that is some way to power down the USB interface in the OMAP
and hope that reduces power leakage.

NeilBrown

> 
> The case 3 might not be very accurate, because in those 14mA is accounted 
> power used for device booting. I'll retry it using longer time period.
> 
> Btw new QtMoko with this charging graph feature is now building.
> 
> Regards
> 
> Radek
> 
> [1] http://projects.goldelico.com/p/gta04-kernel/page/Wireless/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130915/137fa448/attachment.bin>


More information about the Gta04-owner mailing list