[Gta04-owner] Impressions from running Replicant

Dr. H. Nikolaus Schaller hns at goldelico.com
Tue Jun 25 12:15:12 CEST 2013


Am 25.06.2013 um 12:07 schrieb Alexander Rumyantsev:

>> Hi,
>> finally I have found some time to experiment with Replicant
>> and Android (well, when digging deeply into hardware design,
>> production issues and kernel bugs there isn't plenty room
>> for learning something new).
>> I made an SD card with a Replicant image (2.3), put it into the
>> GTA04 (L2804) and after a while the nice red replicant
>> robot did appear. Then, the android home screen came
>> up! Fine!
>> My first impression is that it has some similarities with
>> QtMoko (it is difficult to judge who did take which ideas
>> from whom and some may even have the same source
>> or have become common knowledge).
>> It wasn't really difficult to find out how it works, how to power
>> on/off the device, how to get back to the start screen. How
>> to go to the settings. Even finding a Terminal program
>> wasn't difficult.
>> The only strange effect I have is that when powering off, the
>> screen becomes dark. But on powering on again, I just see a
>> small blinking underscore cursor and the Android GUI has
>> gone :(
> Please, try
> https://docs.google.com/file/d/0B-rRgKAzYyoBbVdIS0l6aXY4SGc/edit?usp=sharing
> The problem was solved. 
> To prepare working SD execute ./replicant_gta04_install.sh
> system /dev/sdb into restored
> directory. ( change /dev/sdb to your device ). 
> Boot from 1 partition using ordinary ( HW-testing/QT ) uBoot from NAND.


How was it solved? I would like to build it from sources (at least in
the future) and I think I have used the latest ones... So a pure rootfs
does not help much beyond showing that it can be solved.

>> I did not find a trick to get it back. Pressing the power button
>> just toggles on/off. Inserting an USB cable makes the power
>> LED become green (i.e. to indicate charging).
>> I have not tested with a SIM card so I can't tell how well
>> UMTS and telephony are working.
>> Then I installed Eclipse and the android developer tools
>> and found an exampe code to program a small pocket
>> calculator. This did need some time to debug because
>> there are minor changes between the screen shots and
>> my Eclipse installation. After approx. 2 hours of work the
>> code did run in the Android emulator.
>> Then I booted the GTA04, plugged in the USB cable
>> and tried to run the code on the GTA04. This was really
>> easy! The GTA04 did show up on the list of devices,
>> download was done automatically and my pocket
>> calculator did run on the GTA04. Within less than 2
>> minutes.
>> So I must say I am really impressed what the Replicant
>> developers have crafted! Kudos to you and keep up your
>> great work!
>> I am starting to think about making a goldelico supported
>> replicant image so that future GTA04 owners can order
>> it right away on a big SD card. This might help a little
>> to increase interest in our work, although it is obvious that
>> the GTA04 does not really stand out in the big, big crowd
>> of Android devices.
>> Nikolaus
> Please, some support to solve kernels problem!!!!!!!!!

If I find some time... And manage to build from sources :)

So many interesting topics are still waiting for integration/backporting
from the 3.7-neil-plus kernel. E.g. the camera :)


More information about the Gta04-owner mailing list