[Gta04-owner] hw routing audio patch removed in 3.7?

Dr. H. Nikolaus Schaller hns at goldelico.com
Mon Jun 10 09:38:24 CEST 2013

Am 08.06.2013 um 21:09 schrieb Andreas Kemnade:

> Hi,
> On Sat, 2013-06-08 at 18:43 +0200, Dr. H. Nikolaus Schaller wrote: 
>> Am 08.06.2013 um 17:14 schrieb Andreas Kemnade:
>>> Hi,
>>> On Sat, 2013-06-08 at 14:30 +0200, Dr. H. Nikolaus Schaller wrote: 
>>>> Hi,
>>>> Am 08.06.2013 um 14:13 schrieb Andreas Kemnade:
>>>>> Hi,
>>>>> i am looking through the commit logs and see that Benjamin Deering has
>>>>> sent my hardware routing patch again (that is for example here:
>>>>> https://github.com/radekp/linux-2.6/commit/f43ce5c444de7db988ad214257f4a6ac0e49308d )
>>>>> in January and it was applied to 3.7. Then it was removed due to white
>>>>> noise.
>>>> Yes, I tried and removed it again.
>>>>> Under which circumstances there was white noise?
>>>> It simply played white noise on the handsfree speaker after using the
>>>> speaker through aplayer for the first time and I did not find any alsa
>>>> control that influenced it.
>>>> If I remember correctly, it did not disappear until reboot.
>>> I added it again, and... i had white noise.
>>>> Removing the patch completely made it work again.
>>> looking at my mixer settings, i found the AVADC clock priority setting
>>> not set to hifi. Changing that disables the white noise. But that is
>>> nothing new and the reason is quite obvious.
>>> Do you have still your mixer settings causing the trouble?
>> Hm. I think I had a fresh installation with default settings, i.e. no state file.
> I removed my state file, then rebooted, and most is muted, i hear
> nothing. I tried then to unmute stuff and then even with wrong AVADC
> everything was fine.

Ok, noise is back, i.e. more options to identify issues.

1. it appears first when running the hw-test script.
2. it does not appear with aplay -q /usr/share/sounds/alsa/Front_Center.wav
3. but it appears with arecord | tee /tmp/echo.wav | aplay

While the command 3 is running there is intensive noise mixed into
the microphone signal. It works fine on a kernel without the patch.

AVADC gives:

root at gta04:~# amixer sget 'AVADC Clock Priority'                      
Simple mixer control 'AVADC Clock Priority',0
  Capabilities: enum
  Items: 'Voice high priority' 'HiFi high priority'
  Item0: 'Voice high priority'
root at gta04:~# 

After changing to HiFi priority the arecord | aplay works without noise.
Setting back to Voice high priority makes the noise come back.

So the question remains why it is not observed without the hw-routing


More information about the Gta04-owner mailing list