[Gta04-owner] Camera scaling down to VGA

Andreas Kemnade andreas at kemnade.info
Sat Jun 8 20:50:57 CEST 2013


On Sat, 2013-06-08 at 18:25 +0200, Dr. H. Nikolaus Schaller wrote: 
> Am 07.06.2013 um 20:57 schrieb Andreas Kemnade:
> > Hi,
> > here are some magic lines to get vga resolution (video downscaled to vga via OMAP3 ISP)
> > 
> > media-ctl -r -l '"ov9655 2-0030":0->"OMAP3 ISP CCDC":0[1], "OMAP3 ISP CCDC":1->"OMAP3 ISP resizer":0[1], "OMAP3 ISP resizer":1->"OMAP3 ISP resizer output":0[1]'
> > export DEVICE=$(media-ctl -e "OMAP3 ISP CCDC output")
> > media-ctl -V '"ov9655 2-0030":0 [UYVY2X8 1280x1024]'
> > media-ctl -V '"OMAP3 ISP CCDC":1 [UYVY2X8 1280x1024]'
> > media-ctl -V '"OMAP3 ISP resizer":1 [UYVY 640x480]'
> > mplayer tv:// -vf rotate=2 -tv driver=v4l2:device=$(media-ctl -e "OMAP3 ISP resizer output"):outfmt=uyvy:width=640:height=480:fps=30 -vo x11
> > 
> > maybe that is helpful for someone...
> I have also added that to the ./camera-demo script [1] of the unstable Wheezy system [2].
> It works - almost. Only the vertical sync does not sync...
I do not understand yet, what is going on, I tried capturing images with

and then 
convert UYVY:name name.jpg
with the resulting captures. They look synced. Maybe mplayer is not fast
enough with collecting data? I still get nearly 100% cpu load.

Andreas Kemnade

More information about the Gta04-owner mailing list