[Gta04-owner] 3G internet connection

Dr. H. Nikolaus Schaller hns at goldelico.com
Sun Apr 21 22:45:00 CEST 2013


Am 21.04.2013 um 01:09 schrieb Sven:

> 
> I know it had already been discussed for several times, but now also I want to have the problem solved that I get only 2G connections...
> 
> Since beginning of this week I use a new provider (eplus BASE). Everything is fine now, but one problem remained: I only get 2G connections. There's only a "G" being displayed by Qtmoko v55 instead of a "3" and browsing within the net is still awfully slow.
> 
> In order to be sure that this time the problem is not caused by the provider as it was the case with my previous one (1&1), today I bought a surfstick (Huawei E392) and connected it to my netbook (Ubuntu 11.04). At first I was impressed that at once it offered me a Linux installation, although the box and the documentation stated that it could only run on Win and Mac OS X. Installation of this software was very easy and at first trial it connected to 3G. Browsing with Firefox was impressing fast. So it's clear that this time it's no problem with my (new) provider. This stick is even able to do 4G LTE, but obviously my provider can't (this was expected, but when I saw this stick, I couldn't resist to buy it...).
> 
> But when I restore the SIM to my GTA04, I still only get a "G" and browsing is very slow.
> 
> After some struggle how to handle and activate the logging options, I can provide you the AT log that you requested in previous discussions of this theme. I tried it twice and to my surprise the ATs are slightly different.
> 
> 1st trial to enable internet access:
> 
> --------%<----------
> 
> Jan  1 02:16:46 neo kernel: imklog 5.8.11, log source = /proc/kmsg started.
> Jan  1 02:16:46 neo rsyslogd: [origin software="rsyslogd" swVersion="5.8.11" x-pid="2504" x-info="http://www.rsyslog.com"] start
> Jan  1 02:16:49 neo Qtopia: AtChat :  N : "_OSIGQ: 23,0"

this appears to be very good and you should be able to get a good connection.

> Jan  1 02:16:52 neo Qtopia: AtChat :  T : "AT_OWANCALL=1,0,1"
> Jan  1 02:16:52 neo Qtopia: AtChat :  F : "AT_OWANCALL=1,0,1"
> Jan  1 02:16:52 neo Qtopia: AtChat :  F : "OK"
> Jan  1 02:17:05 neo Qtopia: AtChat :  N : "_OSIGQ: 20,0"
> Jan  1 02:17:15 neo Qtopia: AtChat :  N : "_OSIGQ: 22,0"
> Jan  1 02:17:19 neo Qtopia: AtChat :  T : "AT+CGDCONT=1,"IP","internet.eplus.de""
> Jan  1 02:17:19 neo Qtopia: AtChat :  F : "AT+CGDCONT=1,"IP","internet.eplus.de""
> Jan  1 02:17:19 neo Qtopia: AtChat :  F : "OK"
> Jan  1 02:17:19 neo Qtopia: AtChat :  T : "AT_OWANCALL=1,1,1"
> Jan  1 02:17:19 neo Qtopia: AtChat :  F : "AT_OWANCALL=1,1,1"
> Jan  1 02:17:19 neo Qtopia: AtChat :  F : "OK"
> Jan  1 02:17:19 neo Qtopia: AtChat :  T : "AT_OWANDATA?"
> Jan  1 02:17:19 neo Qtopia: AtChat :  F : "AT_OWANDATA?"
> Jan  1 02:17:19 neo Qtopia: AtChat :  F : "OK"
> Jan  1 02:17:20 neo Qtopia: AtChat :  T : "AT_OWANDATA?"
> Jan  1 02:17:20 neo Qtopia: AtChat :  N : "_OWANCALL: 1, 1"
> Jan  1 02:17:20 neo Qtopia: AtChat :  F : "AT_OWANDATA?"
> Jan  1 02:17:20 neo Qtopia: AtChat :  N : "_OWANDATA: 1, 10.119.64.117, 0.0.0.0, 212.23.115.132, 212.23.115.148, 0.0.0.0, 0.0.0.0,144000"

This means that the connection speed is 144000. I am not sure in which units...

> Jan  1 02:17:35 neo Qtopia: >>> NO help exists for "logging"
> Jan  1 02:17:48 neo Qtopia: AtChat :  N : "_OSIGQ: 20,0"
> Jan  1 02:17:51 neo Qtopia: AtChat :  N : "_OSIGQ: 18,0"
> Jan  1 02:18:41 neo Qtopia: AtChat :  N : "_OSIGQ: 16,0"
> 
> -------->%----------
> 
> 2nd trial to enable internet access:
> 
> --------%<----------
> 
> Jan  1 02:22:41 neo kernel: imklog 5.8.11, log source = /proc/kmsg started.
> Jan  1 02:22:41 neo rsyslogd: [origin software="rsyslogd" swVersion="5.8.11" x-pid="2633" x-info="http://www.rsyslog.com"] start
> Jan  1 02:22:42 neo Qtopia: AtChat :  N : "_OSIGQ: 21,0"
> Jan  1 02:22:50 neo Qtopia: AtChat :  T : "AT+CGDCONT=1,"IP","internet.eplus.de""
> Jan  1 02:22:50 neo Qtopia: AtChat :  F : "AT+CGDCONT=1,"IP","internet.eplus.de""
> Jan  1 02:22:50 neo Qtopia: AtChat :  F : "OK"
> Jan  1 02:22:50 neo Qtopia: AtChat :  T : "AT_OWANCALL=1,1,1"
> Jan  1 02:22:50 neo Qtopia: AtChat :  F : "AT_OWANCALL=1,1,1"
> Jan  1 02:22:50 neo Qtopia: AtChat :  F : "OK"
> Jan  1 02:22:50 neo Qtopia: AtChat :  T : "AT_OWANDATA?"
> Jan  1 02:22:50 neo Qtopia: AtChat :  F : "AT_OWANDATA?"
> Jan  1 02:22:50 neo Qtopia: AtChat :  F : "OK"
> Jan  1 02:22:50 neo Qtopia: AtChat :  T : "AT_OWANDATA?"
> Jan  1 02:22:50 neo Qtopia: AtChat :  N : "_OWANCALL: 1, 1"
> Jan  1 02:22:50 neo Qtopia: AtChat :  F : "AT_OWANDATA?"
> Jan  1 02:22:50 neo Qtopia: AtChat :  N : "_OWANDATA: 1, 10.248.4.94, 0.0.0.0, 212.23.115.148, 212.23.115.132, 0.0.0.0, 0.0.0.0,144000"
> Jan  1 02:22:59 neo Qtopia: AtChat :  N : "_OSIGQ: 19,0"
> Jan  1 02:23:06 neo Qtopia: AtChat :  N : "_OSIGQ: 16,0"
> Jan  1 02:23:09 neo Qtopia: AtChat :  N : "_OSIGQ: 18,0"
> Jan  1 02:23:26 neo Qtopia: AtChat :  N : "_OSIGQ: 15,0"
> Jan  1 02:23:29 neo Qtopia: AtChat :  N : "_OSIGQ: 11,0"
> Jan  1 02:23:32 neo Qtopia: AtChat :  N : "_OSIGQ: 14,0"
> Jan  1 02:23:39 neo Qtopia: AtChat :  N : "_OSIGQ: 16,0"
> Jan  1 02:23:42 neo Qtopia: AtChat :  N : "_OSIGQ: 18,0"
> 
> -------->%----------
> 
> It might also be useful to know that this provider requires user ("eplus") and password ("eplus"), so I supplied both.
> 
> Any help appreciated.
> 
>   Sven
> 
> 
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner



More information about the Gta04-owner mailing list