[Gta04-owner] Experimental QtMoko/GTA04 build for armhf

Gilles Filippini gilles.filippini at free.fr
Wed Oct 24 13:21:56 CEST 2012


> De: "Neil Jerram" <neil at ossau.homelinux.net>
> Envoyé: Mercredi 24 Octobre 2012 01:43:45
> I spoke a bit too soon...
> 
>   neil at neil-laptop:~/qtv46/qtmoko$ CROSSARCH=armhf CROSSVERS=4.7
>   DIST=wheezy QTMOKO_DEVICES=gta04 pdebuild-cross
>   ...
>   dpkg: warning: downgrading libgomp1-armhf-cross from 4.7.2-4 to
>   4.7.1-7
>   Preparing to replace libgomp1-armhf-cross 4.7.2-4 (using
>   .../libgomp1-armhf-cross_4.7.1-7_all.deb) ...
>   ...
>   dpkg: warning: downgrading libstdc++6-armhf-cross from 4.7.2-4 to
>   4.7.1-7
>   Preparing to replace libstdc++6-armhf-cross 4.7.2-4 (using
>   .../libstdc++6-armhf-cross_4.7.1-7_all.deb) ...
>   ...
>   dpkg: warning: downgrading linux-libc-dev-armhf-cross from 3.2.30-1
>   to 3.2.23-1
>   Preparing to replace linux-libc-dev-armhf-cross 3.2.30-1 (using
>   .../linux-libc-dev-armhf-cross_3.2.23-1_all.deb) ...
>   ...
>   Setting up libqt4-declarative-armhf-cross (4:4.8.2+dfsg-2) ...
>   Setting up libqt4-designer-armhf-cross (4:4.8.2+dfsg-2) ...
>   Setting up libqt4-help-armhf-cross (4:4.8.2+dfsg-2) ...
>   Setting up libqt4-qt3support-armhf-cross (4:4.8.2+dfsg-2) ...
>   Setting up libqt4-scripttools-armhf-cross (4:4.8.2+dfsg-2) ...
>   Setting up libqt4-svg-armhf-cross (4:4.8.2+dfsg-2) ...
>   Setting up libqt4-dev-bin-armhf-cross (4:4.8.2+dfsg-2) ...
>   Setting up libqt4-dev-armhf-cross (4:4.8.2+dfsg-2) ...
>   Reading package lists...
>   Building dependency tree...
>   Reading state information...
>   Correcting dependencies... Done
>   The following extra packages will be installed:
>     libgcc1-armhf-cross libgomp1-armhf-cross libstdc++6-armhf-cross
>   The following packages will be upgraded:
>     libgcc1-armhf-cross libgomp1-armhf-cross libstdc++6-armhf-cross
>   3 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
>   Need to get 332 kB of archives.
>   After this operation, 886 kB of additional disk space will be used.
>   Do you want to continue [Y/n]? Abort.
>   E: pbuilder-satisfydepends failed.
>   I: Copying back the cached apt archive contents
>   I: unmounting dev/pts filesystem
>   I: unmounting proc filesystem
>   I: cleaning the build env
>   I: removing directory /var/lib/pdebuild-cross/build//15252 and its
>   subdirectories
>   neil at neil-laptop:~/qtv46/qtmoko$
> 
> Do you know the reason for that 'Abort'?  As the transcript shows,
> the
> problematic packages appear to be those that were previously flagged
> as
> being downgraded.  I tried a second time (i.e. 'CROSSARCH=armhf
> CROSSVERS=4.7 DIST=wheezy QTMOKO_DEVICES=gta04 pdebuild-cross' again)
> in
> case it was something random, but I got exactly the same output
> again.

>From what I understand, the emdebian repository had its toolchains
upgraded on the 23/10/2012 [1]. It may be broken at the moment: it's now
impossible to create a pdebuild chroot with my scripts :(

[1] <http://emdebian.org/debian/pool/main/g/>

I'll have a deeper look this evening.

Thanks,

_g.


More information about the Gta04-owner mailing list