[Gta04-owner] Newbie alert: GTA04 starting issues

Boudewijn wankelwankel at yahoo.com
Mon Oct 22 21:58:22 CEST 2012


On Monday 22 October 2012 14:05:40 Sam Muirhead wrote:
> I'm a new user of the Open Phoenux, and I'm struggling to get things
> working, and I've got a few questions - the first one is should I be
> writing this here, or in the Community Nachrichtensammlung, or on a forum?
Here is the right place. Some discussions are on this list as well as on the 
Openmoko community list.

> Bear in mind that I'm not particularly experienced with this kind of
> thing, so don't assume I've done the basics right, there are all sorts
> of areas where I could have gone wrong so I'll just go through what I
> tried:
(...)
Looks good to me :-)

> I then inserted the SD card and tried to boot the GTA04. (not plugged
> into USB)
> The gta04 init bootloader screen appeared, and I tried to select the SD
> card, but nothing happened. no response, no sound, no visible change.
> I waited for one minute or so, then tried selecting NAND, just to see if
> it would do anything - still no change.
> I removed the battery, removed the SD card, replaced the battery and
> tried to just boot to lxde again.
> It didn't boot, there was no light from the power button, no other signs
> of life.
The last case "It didn't boot" means: not the bootloader either, after 
replacing the uSD? 
My bootloader, or maybe the touchscreen driver, seems to crash sometimes as 
well. In some cases I can prevent it from freezing by connecting the USB after 
the bootloader screen has been visible for a couple of seconds. I have no 
proof that it is not a coincidence though, so don't start running circles at 
full moon to get it to boot, once your battery is full ;-)

> -It was around this point that I read something saying the battery
> should be fully charged when installing an OS - I don't know how much
> charge was on the battery when I started, but it took me a long time
> organising the SD card so it may have been low by the time I tried to
> boot it.
I expect the phone being connected to your system via USB, while working on 
the uSD, or was it just lying around? As long as it keeps charging, USB 
provides enough power to run the phone and charge the battery.

> Previously when plugged in via USB I at least had a notification that a
> wired network was active, but now there is no sign of a USB device being
> plugged in (at least I don't think there is). I'm running ubuntu 12.04
> on a Macbook Pro:
This is what tail -f /var/log/messages tells while turning on and showing the 
bootloader screen:
Oct 22 21:38:31 tp kernel: [345675.170991] usb 1-1.2: new full-speed USB 
device number 7 using ehci_hcd

Without the battery inserted the screen flashes, but to short to give any 
output via USB.

I don't have a flat battery at the moment; this morning the phone would not 
boot from the bootloader screen at first try. Now it did, though I 
disconnected USB while the system prepared for the bootloader screen, I then 
tapped "boot from uSD" , connected USB and tapped "boot from uSD" again. Then 
it booted, giving these entries in /var/log/messages on my laptop:

Oct 22 21:38:57 tp kernel: [345701.012543] usb 1-1.2: new high-speed USB 
device number 8 using ehci_hcd
Oct 22 21:38:57 tp kernel: [345701.107750] usb 1-1.2: New USB device found, 
idVendor=0525, idProduct=a4a2
Oct 22 21:38:57 tp kernel: [345701.107757] usb 1-1.2: New USB device strings: 
Mfr=1, Product=2, SerialNumber=0
Oct 22 21:38:57 tp kernel: [345701.107762] usb 1-1.2: Product: RNDIS/Ethernet 
Gadget
Oct 22 21:38:57 tp kernel: [345701.107765] usb 1-1.2: Manufacturer: Linux 
3.5.0-gta04-qtmoko-v48 with musb-hdrc
Oct 22 21:38:57 tp mtp-probe: checking bus 1, device 8: 
"/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2"
Oct 22 21:38:57 tp mtp-probe: bus: 1, device: 8 was not an MTP device
Oct 22 21:38:57 tp kernel: [345701.512751] cdc_ether 1-1.2:1.0: usb0: register 
'cdc_ether' at usb-0000:00:1a.0-1.2, CDC Ethernet Device, 46:0d:9e:67:69:eb
Oct 22 21:38:57 tp kernel: [345701.512951] usbcore: registered new interface 
driver cdc_ether
Oct 22 21:38:57 tp kernel: [345701.513981] usbcore: registered new interface 
driver cdc_subset

> So am I right in saying that I have a flat battery that won't charge?
> Or have I missed something important along the way?
It is what Benjamin wrote: keep it connected, it will trickle-charge for quite 
a while, than start flashing the screen on and off, until it accumulates 
enough charge to reach the bootloader screen. 

If I recall correctly, the bootloader screen got enough intelligence to ask 
for a higher current (and charge faster). I'm not sure about that anymore 
though (it was in Radeks bootscreen documentation, but I can't find it at the 
moment).

> Any suggestions for the next step I should try, or is there any further
> information I should supply?
Maybe one more thing: do you have an Openmoko charger, or another high(er) 
power charger? That will charge your battery faster than a USB port of course, 
but besides that, the powermanagement chip seems quite picky about the current 
it receives from the host. Alexander has given a list of creative ways of 
discharging the battery (which I could not find eiter, but I found another 
more to the point discussion about power at boot up: 
http://lists.goldelico.com/pipermail/gta04-owner/2011-November/000659.html

Good luck!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121022/9264728b/attachment.bin>


More information about the Gta04-owner mailing list