[Gta04-owner] [QtMoko] no sound during call (GTA04a3, QtMv48)

Radek Polak psonek2 at seznam.cz
Wed Oct 17 14:00:23 CEST 2012


On Wednesday, October 17, 2012 12:16:34 AM Neil Jerram wrote:

> Neil Jerram <neil at ossau.homelinux.net> writes:
> > I think voice notes are flaky for me too.
> 
> [...]
> 
> >> Oct 6 01:07:13 neo kernel: [ 1157.022979] twl4030-codec twl4030-codec:
> >> operation mode cannot be changed on-the-fly
> > 
> > I have occurrences of that in my logs too.  It appears always to occur
> > in this combination:
> > 
> > Oct  6 16:55:09 neo kernel: [13816.386840] twl4030-codec twl4030-codec:
> > operation mode cannot be changed on-the-fly Oct  6 16:55:09 neo Qtopia:
> > alsactl returned  "alsactl: set_control:1388: Cannot write control
> > '2:0:0:Codec Operation Mode:0' : Device or resource busy Oct  6 16:55:09
> > neo Qtopia: " , running kill-snd-card-users.sh
> > Oct  6 16:55:10 neo Qtopia: killing 1652
> 
> Here's an A3 patch that handles that codec error more gracefully, and
> appears to improve voice notes and media playback for me.  A fairly full
> description is in the patch itself.

Hmm now it starts to look too hackish. How about this idea:

Let's split the state files into 2 sets - for A3 and for A4. Since A3 does not 
need to switch "Codec Operation Mode" at all, we can remove this control from 
state files.

Until now i was quite busy with finishing Qt 4.8.3 upgrade, but i would like to 
take a look at media server - why it gets stuck. Maybe we can also switch from 
cruxus to gstreamer.

Regards

Radek


More information about the Gta04-owner mailing list