[Gta04-owner] Experimental QtMoko/GTA04 build for armhf

Neil Jerram neil at ossau.homelinux.net
Fri Oct 5 21:58:00 CEST 2012


Radek Polak <psonek2 at seznam.cz> writes:

> Some things are working, some not

Here's a log for one of the not working things, GPRS:

Oct  5 20:51:29 neo Qtopia: Network :  QN: Found  ("/home/root/Applications/Network/config/hso0.conf") 
Oct  5 20:51:29 neo Qtopia: Network :  QN::loadPLugin() : plugin found, loaded and new interface instanciated  
Oct  5 20:51:29 neo Qtopia: Network :  new Option3gPlugin interface instance requested ->  "/home/root/Applications/Network/config/hso0.conf" 
Oct  5 20:51:29 neo Qtopia: Network :  Creating HsoInterface instance 
Oct  5 20:51:39 neo Qtopia: AtChat :  N : "_OSIGQ: 30,0" 
Oct  5 20:51:43 neo Qtopia: Network :  Starting interface -> "/home/root/Applications/Network/config/hso0.conf" 
Oct  5 20:51:43 neo Qtopia: Network :  QN: Found  ("/home/root/Applications/Network/config/hso0.conf") 
Oct  5 20:51:43 neo Qtopia: Network :  QNS::startInterface: starting  "/home/root/Applications/Network/config/hso0.conf" 
Oct  5 20:51:43 neo Qtopia: AtChat :  T : "AT+CGDCONT=1,"IP","general.t-mobile.uk"" 
Oct  5 20:51:43 neo Qtopia: Network :  Creating network session for "netsetup" on "/home/root/Applications/Network/config/hso0.conf" 
Oct  5 20:51:43 neo Qtopia: AtChat :  F : "AT+CGDCONT=1,"IP","general.t-mobile.uk"" 
Oct  5 20:51:43 neo Qtopia: AtChat :  F : "OK" 
Oct  5 20:51:43 neo Qtopia: AtChat :  T : "AT_OWANCALL=1,1,1" 
Oct  5 20:51:43 neo Qtopia: AtChat :  F : "AT_OWANCALL=1,1,1" 
Oct  5 20:51:43 neo Qtopia: AtChat :  F : "OK" 
Oct  5 20:51:43 neo Qtopia: AtChat :  T : "AT_OWANDATA?" 
Oct  5 20:51:43 neo Qtopia: AtChat :  F : "AT_OWANDATA?" 
Oct  5 20:51:43 neo Qtopia: AtChat :  F : "OK" 
Oct  5 20:51:44 neo Qtopia: Network :  QN: Found  ("/home/root/Applications/Network/config/hso0.conf") 
Oct  5 20:51:44 neo Qtopia: Network :  ****** "/home/root/Applications/Network/config/hso0.conf" "Interface hasn't been initialized yet." "" 
Oct  5 20:51:44 neo Qtopia: Network :  Setting extended life time for "/home/root/Applications/Network/config/hso0.conf" to true 
Oct  5 20:51:44 neo Qtopia: AtChat :  T : "AT_OWANDATA?" 
Oct  5 20:51:44 neo Qtopia: AtChat :  N : "_OWANCALL: 1, 1" 
Oct  5 20:51:44 neo Qtopia: AtChat :  F : "AT_OWANDATA?" 
Oct  5 20:51:44 neo Qtopia: Network :  hso wan call ip= "31.114.15.145" , dns1= "149.254.230.7" , dns2= "149.254.192.126" 
Oct  5 20:51:44 neo Qtopia: hso: ifconfig failed with  -2 
Oct  5 20:51:44 neo Qtopia: AtChat :  N : "_OWANDATA: 1, 31.114.15.145, 0.0.0.0, 149.254.230.7, 149.254.192.126, 0.0.0.0, 0.0.0.0,144000" 
Oct  5 20:51:44 neo Qtopia: Network :  Obsolete network session detected on "/home/root/Applications/Network/config/hso0.conf" 
Oct  5 20:51:44 neo Qtopia: Network :  Obsolete session had extended life time 
Oct  5 20:51:44 neo Qtopia: Network :  QN: Found  ("/home/root/Applications/Network/config/hso0.conf") 
Oct  5 20:51:44 neo Qtopia: Network :  ****** "/home/root/Applications/Network/config/hso0.conf" "Interface hasn't been initialized yet." "" 

I guess that's because "ifconfig" isn't installed, and we need whatever
is the modern equivalent of that.  ("ip ..." ?)

      Neil


More information about the Gta04-owner mailing list