[Gta04-owner] QtMoko v49

Dr. H. Nikolaus Schaller hns at goldelico.com
Mon Nov 19 08:21:08 CET 2012


Hi Radek,
great work!

Here are my experiences and recommendations:

I have installed it as described in [1] on a fresh SD card and
tried to boot it on a GTA04A4 with the latest multiboot
system in NAND.

Quite quickly the microSD/NAND/1.sh/2.sh screen appears.

But when choosing 1.sh or 2.sh nothing important happens.
Choosing NAND makes the device reboot.

After pressing the microSD symbol, the Qt recalibration appears.
Fine!

But there is no visual hint that QtMoko is hiding behind this
microSD symbol...

I think this is not really intuitive to use. And is this user interaction
step and choice still useful for anything or can it be completely
removed now with the multi-boot system in NAND?

Another observation:

with the uImage in /rootfs/boot/uImage it is not even required to copy
the uImage to the first FAT partition any more (cp boot/uImage /mnt/p1).

I.e. the first partition can be left empty and can be used for any other purpose
(as long as there is no other kernel). Just unpacking the tar to the
second partition is sufficient.

A final observation - on this unit, the barometer reading was a
little unstable. It did jump between 945 mbar (which is correct) to
values like 750 or 796 mbar. After a while the reading was again ok.

BTW: NeronGPS did work fine!

Finally, I have made a variant of 'makesd' that prepares a SD and
installs QtMoko-v49:

<http://download.goldelico.com/gta04/20121119-GTA04-QtMoko-v49/>

BR,
Nikolaus


Am 17.11.2012 um 16:43 schrieb Radek Polak:

> Hi,
> QtMoko v49 for GTA04 is now available [1]. There have been really many changes 
> this time so be careful :) Complete changelog is here:
> 
>  * using gstreamer as media engine instead of cruxus
>  * using pulseaudio for sounds
>  * using pasuspender to pause media during calls and state switching
>  * fixed DTMF tones on gta04 (Neil Jerram)
>  * fixed USSD message box size (Stefan Rupp)
>  * A3 earpiece state uses HiFi priority (Neil Jerram)
>  * modem is now in 3g mode since modem usb disconnect fix is in kernel
>  * modem dissapearing from usb in now logged to /modem_reenumerate.log
>  * lot of work on debian package (Gilles Filippini)
>  * fixed pkg-config handling (Gilles Filippini)
>  * ogg metadata plugin (Neil Jerram)
>  * fixed empty email content with windows charset (Neil Jerram)
>  * fixed some email content displaying (Neil Jerram)
>  * fixes in QtMaze accelerometer (Neil Jerram)
>  * improvements in svg layouts (adrien)
>  * arora and qx use new accelerometer library (Neil Jerram)
>  * arora provides web access e.g. for web links in email (Neil Jerram)
>  * mokofaen - space for 10 and more satellites (Neil Jerram)
>  * qmplayer scans for webm and mkv now too
>  * ssh access in allowed only on usb now (Paul Ferster, lindi)
>  * updated build instructions - cross building is now done in chroot
>  * using now glib even loop
>  * parallel make option in configure for -build-qt option
>  * pc build
>  * kernel changes:
>  * external gps antenna should work now (Christoph Mair)
>  * avoid errors by stoping omap DMA channels before unlinking (Neil Brown)
>  * CONFIG_TIDSPBRIDGE=m so that we can use dsp
>  * jffs2 as module so that we can mount hw validation in nand 
>  * fixed modem disapearing from usb (Dr. H. Nikolaus Schaller)
> 
> The most important thing is that ringtones and sound in calls should now 
> thanks to gstreamer and pulseaudio work. It basically works now like this:
> 
> All sound goes to pulseaudio. When there is a call the state switching and sw-
> voice routing is done via pasuspender. Pasuspender pauses all other audio 
> streams and closes soundcard so that alsactl can do state switching and gsm-
> voice-routing can route voice.
> 
> Please note that pulseaudio is in the image completely unconfigured. It is 
> launched by /opt/qtmoko/pulse.sh scripts. I have noticed occasional clicking - 
> this happens when pulseaudio ends and is restarted. I havent discovered yet 
> why it's ending - maybe "allow-exit = no" option in /etc/pulse/daemon.conf 
> will help...
> 
> You can also try media player - it can now play videos.
> 
> Other changes are quite self explaining.
> 
> As for future - in master we have now nearly working QtMoko on top of Qt 
> 4.8.3. There is just one bug that has to be fixed and it looks that QtMoko now 
> also runs decently on debian wheezy/armhf so this could be our target for v50. 
> We will also have support for html5 video when we switch to qt 4.8 - i have 
> tested youtube and dailymotion and they work (although with glitches)...
> 
> Another thing that would be nice to get fixed is the tarball size. It went 
> from 98MB to 160MB due to gstreamer dependecies. I wonder how this could be 
> solved. I dont think we need all the plugins that make it so big, but debian 
> has all in one big package...
> 
> If you are wondering about Freerunner - i am going to skip this release, 
> there's not much useful for Freeruner now. I will do release for Freerunner 
> with Qt 4.8 later.
> 
> Thanks everybody who helped with this release - special thanks to Neil Jerram 
> and Gilles!
> 
> Enjoy the release
> 
> Radek
> 
> 
> [1] http://sourceforge.net/projects/qtmoko/files/GTA04/
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner



More information about the Gta04-owner mailing list