[Gta04-owner] QtMoko - another experimental image

Radek Polak psonek2 at seznam.cz
Thu Nov 15 10:24:49 CET 2012


On Thursday, November 15, 2012 09:25:34 AM Neil Jerram wrote:

> I found that I needed "xapt -a armel -m libpulse-dev" to build the
> latest code (093cf8925316ba8e43cab119d888006c8e6b03ea).  I think that's
> the same as adding libpulse-dev to the big "xapt -a armel ..." line in
> scripts/qtmoko-chroot.sh, and presumably libpulse-dev should also be
> added to the Debian Build-Deps.

Oki, maybe pini has patch for this already.

> (BTW I noticed an unrelated difference between Build-Deps and the xapt
> line, for libjpeg8-dev.)

I am not sure what is correct here. In older versions we had libjpeg62 + 
libmng + libtiff dependecy. Then i changed it to libjpeg8 - probably because 
of wheezy builds. Now it's again back on libjpeg62 + libmng + libtiff.

I wonder if this is intended or not and which dependency is right for us?

> Should we be using --system?  If so, are those warnings OK?  If not, is
> there something else needed in the rootfs to allow successful startup
> (without --system)?

Hmm for me it starts ok, maybe i have some more dependecies. I am now 
installing:

pulseaudio pulseaudio-utils gstreamer0.10-ffmpeg gstreamer0.10-plugins-good 
gstreamer0.10-pulseaudio

We should probably not use --system since it does not use shared memory and 
could perform worse then.

Regards

Radek


More information about the Gta04-owner mailing list