[Gta04-owner] Data connection with ofono and connman

Neil Jerram neil at ossau.homelinux.net
Thu Feb 23 23:08:50 CET 2012


I'm trying to set up a data connection (GPRS), with ofono and connman,
by:

gta04:~/connman/test# ./test-connman state
System is offline
gta04:~/connman/test# ./test-connman services
  T-Mobile                   { cellular_234308386699287_context1 }
gta04:~/connman/test# ./test-connman connect cellular_234308386699287_context1
net.connman.Error.Failed: Input/output error

I believe the Input/output error is benign - it just means that I don't
have an input agent running to respond to a report that the connection
failed and a "Retry service (yes/no)" prompt.  The important point is
that the connection fails before that.  The log around the time of the
failure has:

Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:connect_service() service 0x7f1f50
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:__connman_service_connect() service 0x7f1f50 state idle
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/stats.c:__connman_stats_service_register() service 0x7f1f50
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/ipconfig.c:__connman_ipconfig_enable() ipconfig 0x7f2140
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/ipconfig.c:__connman_ipconfig_enable() ipconfig 0x7f21b0
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/network.c:__connman_network_connect() network 0x7f1e88
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/device.c:__connman_device_disconnect() device 0x7eee90
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/device.c:connman_device_set_disconnected() device 0x7eee90 disconnected 1
Feb 23 21:52:11 gta04 daemon.warn connmand[976]: Skipping disconnect of /hso_0/context1, network is connecting.
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: plugins/ofono.c:network_connect() /hso_0 network 0x7f1e88
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: plugins/ofono.c:context_set_active() /hso_0 active 1
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: plugins/ofono.c:set_property() /hso_0 path /hso_0/context1 org.ofono.ConnectionContext.Active
Feb 23 21:52:11 gta04 daemon.info ofonod[978]: Control: > AT$QCPDPP=1,0\r
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/network.c:connman_network_set_associating() network 0x7f1e88 associating 1
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:__connman_service_lookup_from_network() network 0x7f1e88
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:__connman_service_ipconfig_indicate_state() service 0x7f1f50 (cellular_234308386699287_context1) state 2 (association) type 1 (IPv4)
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:service_indicate_state() service 0x7f1f50 old idle - new association/idle => association
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/session.c:service_state_changed() service 0x7f1f50 state 2
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/notifier.c:notify_idle_state() idle 0
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/manager.c:idle_state() idle 0
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:services_changed() 
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/connection.c:find_active_gateway() 
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/connection.c:update_order() 
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:__connman_service_ipconfig_indicate_state() service 0x7f1f50 (cellular_234308386699287_context1) state 2 (association) type 2 (IPv6)
Feb 23 21:52:11 gta04 daemon.debug connmand[976]: src/service.c:service_indicate_state() service 0x7f1f50 old association - new association/association => association
Feb 23 21:52:12 gta04 daemon.info ofonod[978]: Control: < \r\nOK\r\n
Feb 23 21:52:12 gta04 daemon.info ofonod[978]: Control: > AT+CGDCONT=1,"IP",""\r
Feb 23 21:52:12 gta04 daemon.info ofonod[978]: Control: < \r\nOK\r\n
Feb 23 21:52:12 gta04 daemon.info ofonod[978]: Control: > AT_OWANCALL=1,1,1\r
Feb 23 21:52:12 gta04 daemon.info ofonod[978]: Control: < \r\nOK\r\n
Feb 23 21:52:13 gta04 daemon.info ofonod[978]: App: < \r\n_OSIGQ: 10,0\r\n
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: plugins/ofono.c:netreg_update_strength() /hso_0 Strength 32
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: src/network.c:connman_network_set_strength() network 0x7f1e88 strengh 32
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: src/service.c:__connman_service_update_from_network() network 0x7f1e88
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: src/service.c:__connman_service_lookup_from_network() network 0x7f1e88
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: src/network.c:connman_network_get_string() network 0x7f1e88 key Name
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: src/network.c:connman_network_get_bool() network 0x7f1e88 key Roaming
Feb 23 21:52:13 gta04 daemon.info ofonod[978]: App: < \r\n+CGEV: NW DEACT IP, 0.0.0.0, 1\r\n
Feb 23 21:52:13 gta04 daemon.info ofonod[978]: Control: < _OWANCALL: 1, 3\r\n
Feb 23 21:52:13 gta04 daemon.debug ofonod[978]: drivers/hsomodem/gprs-context.c:owancall_notifier() HSO Context: failed
Feb 23 21:52:13 gta04 daemon.debug ofonod[978]: src/gprs.c:pri_activate_callback() 0x88dba0
Feb 23 21:52:13 gta04 daemon.debug ofonod[978]: src/gprs.c:pri_activate_callback() Activating context failed with error: Unknown error type
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: plugins/ofono.c:set_property_reply() /hso_0 path /hso_0/context1 org.ofono.ConnectionContext.Active
Feb 23 21:52:13 gta04 daemon.err connmand[976]: Failed to change property: /hso_0/context1 org.ofono.ConnectionContext.Active: org.ofono.Error.Failed Operation failed
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: plugins/ofono.c:context_set_active_reply() /hso_0
Feb 23 21:52:13 gta04 daemon.debug connmand[976]: src/network.c:connman_network_set_error() nework 0x7f1e88, error 1

Marcel (or anyone else who's knowledgeable here), can you see what's
going wrong (or what I'm doing wrong)?

Thanks,
      Neil


More information about the Gta04-owner mailing list