[Gta04-owner] gsm-voice-routing.c

Radek Polak psonek2 at seznam.cz
Sun Feb 19 21:52:09 CET 2012


On Sunday 19 February 2012 17:19:01 Denis 'GNUtoo' Carikli wrote:

> hi,
> 
> I've tried to run gsm-voice-routing on the gta04 under SHR and I get that:
> >p0 (default): snd_pcm_hw_params_set_period_size failed: Invalid argument
> >retrying in 100 ms
> 
> if I change default to hw:0,0 I still get an error:
> >p0 (hw:0,0): snd_pcm_hw_params_set_channels failed: Invalid argument
> >retrying in 100 ms
> 
> same for dmix:0 and dshare:0 :
> >p0 (dmix:0): snd_pcm_hw_params_set_format failed: Invalid argument
> >retrying in 100 ms

Can you try with qtmoko's kernel?

Other thing to try would be increase period size (i increased it today to 256 
btw, so you can try just update).

> And I get the exact same messages during a call.
> 
> PS: where is the part that makes it work only when there is a call?

        rc = route_stream_read(&r1);
        if (rc == ERR_READ && started) {
            fprintf(logfile,
                    "read error after some succesful routing (hangup)\n");
            return 0;
        }
        if (rc != 0) {
            continue;
        }

First it tries to read from hw:1,0 and until it starts working. On next error 
the program ends up.

Regards

Radek


More information about the Gta04-owner mailing list